This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[CLOSED] OP2 Serial Alias warning on Check System screen
#1
RPi4B 4GB - OP2 2.0.27-stable Serial 2.0.5-stable Cpn 5.0.0 all others up-to-date

I gave Alias names in the serial app. For the ttyACM0 which links to Signal K no problem.

Cpn doesn't see the Alias USB0 from the serial app & creates it's own connection.

This results in a warning message that the Alias is not set. There is no way to correct this that I can find.

Screenshots attached.

Not an issue as such as all works fine, just be nice to clear the warning.

Thanks, Paul

       
  Reply
#2
You do not need to create any USB serial connection in opencpn. Opencpn should have just a network connection: localhost 10110 TCP (the SK connection).

Then you should connect both serial NMEA 0183 devices to signal k in serial app - connections tab. Data from both devices will de available in TCP localhost 10110 multiplexed.
  Reply
#3
Thanks,

So I have set 10110 in Cpn to output as well as input.

Used the serial app & clicked on Add to SigK, set 9,600B. However looking at the Connections in SigK it looks as if that's just for inputs, I want to send 0183 data out from SigK assuming it gets it directly from Cpn via 10110 without any other settings.

The Convert SigK to NMEA0183 is active


I am sure I am missing something here? I haven't found any documentation to help with this, is there any around?

Paul
  Reply
#4
You did not mentioned you want a serial output. Until the kplex app is published you can do this from opencpn. Create in opencpn a serial output and type the alias (opencpn will not found aliases).

If you are connecting NMEA 0183 data to signal k you do not need to convert signal k data into NMEA 0183. Disable Signal k to NMEA 0183 plugin.

Do not send data back to TCP localhost 10110! you are creating a data loop. Disable output in opencpn for localhost 10110 TCP.

Not docs yet, working on it.
  Reply
#5
Thanks, thought it was slowing!

Sorry about the missed important bit  Sad

Typing in the Alias when creating the connection in Cpn creates a duplicate connection in red in OP2 Serial without the "ttyUSB0" device entry, so that won't work. I just selected the port in Cpn & then it works ok with the Alias warning on boot.

Perfectly usable Cool

Thanks for the help.
  Reply
#6
Have you tried typing "/dev/ttyOP_nmeaout"?

Do not worry, normal confusions without docs. Hopefully we can say RTFM soon Smile
  Reply
#7
Yes I typed it exactly as it was shown in your Serial app.

Maybe I should delete the existing device in the serial app first, i didn't do that.

EDIT:
No I Didn't, i missed the /dev/
Now it works & no error.

Thanks again
Paul
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)