This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] CAN BUS - does not start.
#1
Got my http://www.industrialberry.com/canberrydual-v2-1/ today, and was looking forward to getting it installed, but my CAN Bus does not start. I tried to uninstall/reinstall/reboot, but still just an churning hour glass and then nothing. Any advice? Installed the CAN according to canberry's advice on website. I am running a  Rpi 3b.
Edit: for reference, I downloaded CAN bus to my Ubuntu laptop - same thing here. I get an hour glass and then nothing.
  Reply
#2
type openplotter-can in a terminal and copy here the output
  Reply
#3
pi@openplotter:~ $ openplotter-can
Traceback (most recent call last):
File "/usr/bin/openplotter-can", line 11, in <module>
load_entry_point('openplotterCan==2.1.0', 'console_scripts', 'openplotter-can')()
File "/usr/lib/python3/dist-packages/openplotterCan/openplotterCan.py", line 1148, in main
MyFrame().Show()
File "/usr/lib/python3/dist-packages/openplotterCan/openplotterCan.py", line 88, in __init__
self.pageCanable()
File "/usr/lib/python3/dist-packages/openplotterCan/openplotterCan.py", line 370, in pageCanable
self.readCanable()
File "/usr/lib/python3/dist-packages/openplotterCan/openplotterCan.py", line 424, in readCanable
if i['pipeElements'][0]['options']['subOptions']['type']=='canbus-canboatjs':
KeyError: 'type'
  Reply
#4
Your problem is in SK settings.
please copy here the contents of file /home/pi/.signalk/settings.json
  Reply
#5
Can you post your /home/pi/.signalk/settings.json please.

When using openplotter-can to work with mcp2515 you don't need any additional download or system setting (except Signal K is installed and openplotter-settings)!

Anyway this is a bug which will be fixed.
  Reply
#6
(03-18-2020, 06:35 AM)Sailoog Wrote: Your problem is in SK settings.
please copy here the contents of file /home/pi/.signalk/settings.json

{
  "interfaces": {},
  "pipedProviders": [
    {
      "enabled": true,
      "id": "Pypilot Signal K",
      "pipeElements": [
        {
          "options": {
            "logging": false,
            "providerId": "Pypilot Signal K",
            "subOptions": {
              "port": "20220",
              "providerId": "Pypilot Signal K",
              "type": "udp"
            },
            "type": "SignalK"
          },
          "type": "providers/simple"
        }
      ]
    },
    {
      "enabled": true,
      "id": "I2C",
      "pipeElements": [
        {
          "options": {
            "logging": false,
            "providerId": "I2C",
            "subOptions": {
              "port": "51000",
              "providerId": "I2C",
              "type": "udp"
            },
            "type": "SignalK"
          },
          "type": "providers/simple"
        }
      ]
    },
    {
      "enabled": false,
      "id": "gps",
      "pipeElements": [
        {
          "options": {
            "logging": false,
            "subOptions": {
              "baudrate": 4800,
              "device": "/dev/ttyOP_gps",
              "type": "serial",
              "validateChecksum": true,
              "providerId": "gps"
            },
            "type": "NMEA0183",
            "providerId": "gps"
          },
          "type": "providers/simple"
        }
      ]
    },
    {
      "pipeElements": [
        {
          "type": "providers/simple",
          "options": {
            "logging": false,
            "type": "FileStream",
            "subOptions": {
              "dataType": "NMEA2000JS",
              "filename": "/usr/lib/node_modules/signalk-server/samples/aava-n2k.data",
              "providerId": "testfile"
            },
            "providerId": "testfile"
          }
        }
      ],
      "id": "testfile",
      "enabled": true
    },
    {
      "pipeElements": [
        {
          "type": "providers/simple",
          "options": {
            "logging": false,
            "type": "NMEA0183",
            "subOptions": {
              "validateChecksum": true,
              "type": "tcp",
              "host": "10.10.10.128",
              "port": "10110",
              "providerId": "B6G Vulcan"
            },
            "providerId": "B6G Vulcan"
          }
        }
      ],
      "id": "B6G Vulcan",
      "enabled": false
    },
    {
      "pipeElements": [
        {
          "type": "providers/simple",
          "options": {
            "logging": false,
            "type": "NMEA2000",
            "subOptions": {
              "type": "canbus",
              "interface": "can0",
              "providerId": "CAN0"
            },
            "providerId": "CAN0"
          }
        }
      ],
      "id": "CAN0",
      "enabled": true
    }
  ],
  "security": {
    "strategy": "./tokensecurity"
  },
  "ssl": false
}
  Reply
#7
Please download this new version that should fix this issue:
https://launchpad.net/~sailoog/+archive/...le_all.deb

To install it double click the deb file or type:

Code:
sudo dpkg -i openplotter-can_2.1.1-stable_all.deb

Then open the app in menu-> CAN Bus to run the post-installtion scripts and you are done.

Please report so we can promote this version to production.
  Reply
#8
It starts! It runs! It's perfect! (so far) Haven't installed the NMEA 2000 yet, but the sw is up and running! Thanks!
  Reply
#9
going to production
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)