This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sound when connecting liniair actuator on pypilot
#1
Hi,

Quick question, I am using a liniair actuator on the pypilot connected to a h-bridge with a max rating of 40A.
I've set the maximum amp to 20 (as far as the client can go) but I think that will be sufficient.

When the actuator starts to rotate the electromotor within, it sounds different than running it on a "normal" autopilot controller.
It works, but it has a (how should I describe) "whistle" or "constant beep" sound when it activates.

I guess it has to do something with the gains, but no matter what gains I try or amp setting, it keeps making the sound.
When doing long passages, I'd like the motor to be quiet.

Any suggestions?
  Reply
#2
(03-24-2020, 12:06 PM)jamos.tan@gmail.com Wrote: Hi,

Quick question, I am using a liniair actuator on the pypilot connected to a h-bridge with a max rating of 40A.
I've set the maximum amp to 20 (as far as the client can go) but I think that will be sufficient.
If the controller gives the high current flag, the max current is 60 amp. I tried running my regular controller at 20 amps continuously drivingand after about a minute it overheats.

Quote:When the actuator starts to rotate the electromotor within, it sounds different than running it on a "normal" autopilot controller.
It works, but it has a (how should I describe) "whistle" or "constant beep" sound when it activates.

I guess it has to do something with the gains, but no matter what gains I try or amp setting, it keeps making the sound.
When doing long passages, I'd like the motor to be quiet.
Any suggestions?

What hbridge and setup are you using? Do you know the PWM frequency? My controllers normally use a 16khz frequency below 98%, and at 100% a lower frequency which is not audible at full duty.

So, you would only hear the noise maybe when speeding up and slowing down, but it's difficult to hear for most people, but maybe your motor resonates at 16khz to make lower audible frequencies?

If you are using pwm_mode==2 I think it uses 1khz which is very annoying whine, but a lot of those controllers overheat and don't work correctly at higher frequencies. You could try it, but the default in the code is safer.
  Reply
#3
Quote:What hbridge and setup are you using?   Do you know the PWM frequency?   My controllers normally use a 16khz frequency below 98%, and at 100% a lower frequency which is not audible at full duty.

So, you would only hear the noise maybe when speeding up and slowing down, but it's difficult to hear for most people, but maybe your motor resonates at 16khz to make lower audible frequencies?

If you are using pwm_mode==2 I think it uses 1khz which is very annoying whine, but a lot of those controllers overheat and don't work correctly at higher frequencies.   You could try it, but the default in the code is safer.

I am using this h-bridge and it drives a liniair actuator something like this.
Indeed I am using pwm_mode=2 and the actuator whines constantly, so not only at the start.
It has a two-way 25kHZ highest frequency PWM input.

So the trick is to try a higher frequency in the motor.ino, I'll give it a try and monitor the temperature closely.

Thanks for the description of "whine" that descibes it in the best way I suppose Tongue
  Reply
#4
Hmm, can you point me in the right direction? Not sure which part of motor.ino I need to adjust for the khz, found this part but not sure:

  
Code:
  if(pwm_style == 1) {
        TCNT1 = 0x1fff;
        //Configure TIMER1
        TCCR1A=_BV(COM1A1)|_BV(WGM11);        //NON Inverted PWM
        TCCR1B=_BV(WGM13)|_BV(WGM12)|_BV(CS11); //PRESCALER=8 MODE 14(FAST PWM)
        ICR1=40000/DIV_CLOCK;  //fPWM=50Hz (Period = 20ms Standard).
        TIMSK1 = 0;
    } else if(pwm_style == 2) {
        TCNT1 = 0;
        TCCR1A=_BV(COM1A1)|_BV(WGM11);        //NON Inverted PWM
        TCCR1B=_BV(WGM13)|_BV(WGM12)|_BV(CS10); //PRESCALER=0 MODE 14(FAST PWM)

        // use 1khz safe at all speeds.   20khz is nice to avoid
        // audible sound, but you need to set minimum speed to 20-30%
        // or it will overheat the part at very low speeds.
        ICR1=16000/DIV_CLOCK;  //fPWM=1khz
        TIMSK1 = 0;
  Reply
#5
Try decreasing the ICR1=16000 to 800-1000 and you will get 16-20khz.
  Reply
#6
(03-25-2020, 12:52 PM)seandepagnier Wrote: Try decreasing the ICR1=16000 to 800-1000 and you will get 16-20khz.

Tried it, adjusted ICR1=1000 made no effect. Still makes the same noise.
Also tried adjusting the gains in pypilot client, no effect.
Any ideas?
  Reply
#7
Can you verify the signal generated by the arduino is correct? If it drives 20khz you won't hear it, but some hbridge will overheat and others won't so 1khz is safer.

The gains have no effect on high frequency motor noise.
  Reply
#8
(03-26-2020, 08:20 AM)seandepagnier Wrote: Can you verify the signal generated by the arduino is correct?   If it drives 20khz you won't hear it, but some hbridge will overheat and others won't so 1khz is safer.

The gains have no effect on high frequency motor noise.

Hmm, how can I check this? Found this one: https://stackoverflow.com/questions/5034...n-function
  Reply
#9
oscilliscope.. digital analyzer etc..

If you change to 1000 instead of 16000 in that line 644 of motor.ino. Unless it is not actually using pwm_mode==2 I am not sure why you get audible noise.

Changing from 16000 to 8000 would give you 2khz instead of 1khz and the sound should be much higher pitch.
  Reply
#10
(03-26-2020, 02:17 PM)seandepagnier Wrote: oscilliscope.. digital analyzer etc..

If you change to 1000 instead of 16000 in that line 644 of motor.ino.  Unless it is not actually using pwm_mode==2 I am not sure why you get audible noise.  

Changing from 16000 to 8000 would give you 2khz instead of 1khz and the sound should be much higher pitch.

I have pwm mode 2, but I also needed to enable VNH2SP30 or else the motor controller didn't work.
  Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)