This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OP2 Rasp Pi 4 sec display VGA
#1
Hi,

Who has a suggestion ?

I've installed OP2 on an raspberry PI 4. First display in the navigation corner is HDMI based and connected to hdmi0 port on the pi. This works.

I've a second monitor LX1501PTI  mounted outside. This monitor has only a VGA connection and USB connection for converting touch into the mouse movement. This display is excellent (1024x768) , brilliant colors, dimable, and touch works fine so i don't want to replace this display. This display works fine connected to a windows notebook.

I connected this display via a passive VGA to Mini hdmi convertor to port hdmi1 on the PI 4
The problem is i don't get anything on the VGA screen. 
It seems that I should modify  /boot/config.txt  but until now i could not find a working mode.

Ideas are welcome

G
  Reply
#2
Haven't tried that monitor, but in general VGA requires:

Code:
[HDMI:1]
hdmi_force_hotplug=1
hdmi_drive=2
hdmi_group=2
hdmi_mode=16
 [HDMI:1] tells the config to only apply to port 1 on the pi 4, so put this section at the bottom of the file. If you have other required HDMI commands for your main monitor you may need to put them in an [HDMI:0] section (by default they apply to 0, but when you are configuring two monitors best to be explicit).

the hotplug command forces the pi to believe the monitor is connected, whether or not it really is (since it won't get a signal from the VGA port to tell it.)

the drive command selects between DVI (1) and HDMI (2)

the group command says "treat as a monitor (2=monitor, 1=TV).

the mode command is 1024x768@60Hz

depending on system you may also need:

Code:
enable_tvout=0
disable_overscan=0

these are both the default values, but sometimes you have to be explicit about them.

All the pi video options
  Reply
#3
THX dsanduril !

Works now for me.
Display inside on 1920x1080
Display outside on 1024x 768

regards
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)