This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Serial data in and out?
#1
Hi, I am currently running OP 1.0.0 alpha on a RP3 and it works fine with GPS and AIS data in from my em-trak B100 AIS transciever connected with an USB to serial adapter. I would also like to send NMEA 1083-data out to my Raymarine ST1000 autopilot.

In Openplotter i have got one serial connection and 3 Kplex connections added automatically but I can't change the serial connection under Kplex to be both in and out. 

Isn't it possible to have one in/out going serial connection? If it is, how do I set it up? All the wiring is done and worked when I sent NMEA fronm my old GPS to the autopilot.
  Reply
#2
(05-07-2020, 06:03 AM)s99kalle Wrote: Hi, I am currently running OP 1.0.0 alpha on a RP3 and it works fine with GPS and AIS data in from my em-trak B100 AIS transciever connected with an USB to serial adapter. I would also like to send NMEA 1083-data out to my Raymarine ST1000 autopilot.

In Openplotter i have got one serial connection and 3 Kplex connections added automatically but I can't change the serial connection under Kplex to be both in and out. 

Isn't it possible to have one in/out going serial connection? If it is, how do I set it up? All the wiring is done and worked when I sent NMEA fronm my old GPS to the autopilot.

II have a similar setup to you.
GPS,AIS and Raymarine instruments
've now moved onto OP2 but I still have a copy of my old kplex.conf file from OP1.2.
From memory I think you need to go into USB manager, advanced settings.
This opens kplex.conf for manual editing.
In there, define a port like mine below. 
I called mine "Seatlalk" as I use a NMEA/Seatalk bridge ti link to my Seatalk instruments and Autopilot


# For advanced manual configuration, please visit: http://www.stripydog.com/kplex/configuration.html
# Please do not modify defaults nor OpenPlotter GUI settings.
# Add manual settings at the end of the document.

###defaults

[udp]
name=system
direction=in
port=10110

[tcp]
name=signalk
direction=out
mode=server
port=30330


###end of defaults

###OpenPlotter GUI settings

[serial]
name=gps
direction=in
optional=yes
filename=/dev/ttyOP_gps
baud=4800
ifilter=-**GSV

[serial]
name=ais
direction=in
optional=yes
filename=/dev/ttyOP_ais
baud=38400

[serial]
name=seatalk
direction=both
optional=yes
filename=/dev/ttyOP_seatalk
baud=4800
ifilter=-**RMC:-**GLL:-**GGA

###end of OpenPlotter GUI settings

###Manual settings
  Reply
#3
Thank you!
I'll give that a try.
  Reply
#4
(05-07-2020, 07:34 AM)s99kalle Wrote: Thank you!
I'll give that a try.

Come over to the new world of openplotter V2..... Big Grin Cool
Much nicer  Smile
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)