• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No GPS Signal to KPlex
#1
Dear Guys

My problem sounds very similar to the one "Solo" refered to on 9th of january.
I'm working to set up a new system with RPI 3 and Openplotter 0.9.0. When connecting a GPS Antenna (Navilock NL-622MP) and running the setup tool for USB connection, the antenna will be found and you can see the NMEA sentences received from the antenna. The tool installed it as ttyOP_GP.
As next I added the device to the NMEA O183 tabel as
Name: gps
Type: Serial
io: in
Address: ttyOP_GP
Baudrate: 38400 (because it was detected with this rate by the setup tool)
inFilter: no
Filtering: none
outFilter: no
Filtering: none

By using the diagnostic tool, it became clear, that kplex has no signal at all.

Just to find out if the antenna is working in good shape, I changed the input for opencpn direct to ttyUSB0 and it worked perfect with the baudrate of 38400 only.

So I tested around for a while but no solution showed up.
Is there anyone who has an idea what could be wrong with my system?
  Reply
#2
Known issues "https://github.com/sailoog/openplotter/issues/137" There were some language problem with kplex in v0.9.0.
Solution:
1. git clone latest version from github or
2. use only english language
delete all own sentences from kplex (you can't delete the 4 standard sentence system_a,system_b,opencpn,signalk)
add the sentence again
  Reply
#3
(02-13-2017, 05:26 PM)e-sailing Wrote: Known issues "https://github.com/sailoog/openplotter/issues/137" There were some language problem with kplex in v0.9.0.
Solution:
1. git clone latest version from github or
2. use only english language
delete all own sentences from kplex (you can't delete the 4 standard sentence system_a,system_b,opencpn,signalk)
add the sentence again

Dear e-sailing

Many thanks for fast reply. Changing the language to english solved the problem.
Smile
  Reply
#4
Many thanks for sharing such a relevant and helpful post.

Regards
Mike Craig
IT Services
  Reply
#5
Hi,

You are not the only one facing this issue. I did this same mistake of not changing the language under the settings tab. But its good to keep committing mistakes and to keep on learning from them.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)