This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED -> REOPEN for OP 1.1.0] With Openplotter 0.9.0 AIS does not work
#1
I Raspberry pi 3 with Adafruit 10-DOF IMU and rtl usb dongle for ais.
With openplotter 0.8 AIS successfully works, with Openplotter 0.9.0 AIS does not work
I tried 3 different rtl dongle but no one works

Thanks for your help
  Reply
#2
Hello Sailoog, if you want to check I can give you the account for remote connection.
  Reply
#3
Do you use the latest github v0.9.0?

You can test AIS in terminal with:
rtl_fm -f 161975000 -p 0 -s 48k | aisdecoder -h 127.0.0.1 -p 12345 -a file -c mono -d -f /dev/stdin
-p (ppm) has to be adjusted
  Reply
#4
> Do you use the latest github v0.9.0?
Yes

respond:

Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.
  Reply
#5
Do you run the RTL2838 from a powered hub? Some kind of power problem?
What does lsusb say?
  Reply
#6
> the RTL2838 from a powered hub?
Yes

lsusb say:

lsusb -s 006 -v

Bus 001 Device 006: ID 0bda:2838 Realtek Semiconductor Corp. RTL2838 DVB-T
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0bda Realtek Semiconductor Corp.
idProduct 0x2838 RTL2838 DVB-T
bcdDevice 1.00
iManufacturer 1 Realtek
iProduct 2 RTL2838UHIDIR
iSerial 3 00000001
bNumConfigurations 1
Configuration Descriptor:
bLength 9
bDescriptorType 2
wTotalLength 34
bNumInterfaces 2
bConfigurationValue 1
iConfiguration 4 USB2.0-Bulk&Iso
bmAttributes 0x80
(Bus Powered)
MaxPower 500mA
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 0
bAlternateSetting 0
bNumEndpoints 1
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 5 Bulk-In, Interface
Endpoint Descriptor:
bLength 7
bDescriptorType 5
bEndpointAddress 0x81 EP 1 IN
bmAttributes 2
Transfer Type Bulk
Synch Type None
Usage Type Data
wMaxPacketSize 0x0200 1x 512 bytes
bInterval 0
Interface Descriptor:
bLength 9
bDescriptorType 4
bInterfaceNumber 1
bAlternateSetting 0
bNumEndpoints 0
bInterfaceClass 255 Vendor Specific Class
bInterfaceSubClass 255 Vendor Specific Subclass
bInterfaceProtocol 255 Vendor Specific Protocol
iInterface 5 Bulk-In, Interface
Device Qualifier (for other device speed):
bLength 10
bDescriptorType 6
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
bNumConfigurations 2
Device Status: 0x0000
(Bus Powered)
  Reply
#7
Does gqrx work?
pi@openplotter:~/.config/gqrx-2.6-rpi3-1 $ ./run_gqrx.sh
  Reply
#8
gqrx starts, but I do not know if it works ... (I do not know this program)

OK Gqrx works, I see FM radio spectrum and sound waves.
  Reply
#9
Today I went on board:
- I turned off power and back on everything.
- I unplugged the sensor imu
- I repeated the test with a new microSD with a clean install.
- Diagnostic continues to not show the AIS sentences (nothing on system, nothing of opencpn of kplesk).
- If I off "AIS Reception" AIS the from terminal I see the strings:
pi@openplotter:~ $ rtl_fm -f 161975000 -p 0 -s 48k | aisdecoder -h 127.0.0.1 -p 1 -a file -c mono -d -f /dev/stdin
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001
 
Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Tuner gain set to automatic.
Tuned to 162227000 Hz.
Oversampling input by: 21x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 48000 Hz.
!AIVDM,1,1,,A,402Fhbiv4d`UE0ruhtI8PaW0052D,0*1C
!AIVDM,1,1,,A,402FhPAv4d`UK0vB:dHrqSW00`@F,0*04
!AIVDM,1,1,,A,ENjO`A32qIrJ@1WV62h1P`8:QQTPNsn7<NhNp10888N003R@,0*25
!AIVDM,1,1,,A,ENjO`A32qIrJ@1WV62h1P`8:QQTPNsn7<NhNp10888N003R@,0*25
!AIVDM,1,1,,A,402FhPAv4d`UR0vB:dHrqSW00U2D,0*58

I understand the problem and solved!
In .kplex.conf configuration file in the system section must be added the voice address=localhost
This is missing in the files installed by openplotter.
Like this is ok:
[udp]
name=system
direction=in
address=localhost
port=10110
  Reply
#10
Hallo,
with OP 1.1.0 SDR AIS don't work.
if I type:
rtl_fm -f 161975000 -p 128 -s 48k | aisdecoder -h 127.0.0.1 -p 1 -a file -c mono -d -f /dev/stdin
respond:
 -a file -c mono -d -f /dev/stdin                                              

Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Tuner gain set to automatic.
Tuner error set to 128 ppm.
Tuned to 162227000 Hz.
oversampling input by: 21x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Create UDP thread
Created UDP thread
Main socket started! :-) Tuning enabled on UDP/6020
Sampling at 1008000 S/s.
Output at 48000 Hz.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)