This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Voyage Data Recording
#1
I had raised the question for a stand alone vdr in the ocpn cruisers forum and got the advise to use ncat.

What I aim for is a simple way to record the nmea sentences so that I can later load the file into ocpn on any platform and playback the vdr file.

I used the command 

ncat localhost -u -l 10109 -o --append-output mylogdata.txt 
but always got 
Ncat: Got more than one port specification: 10109 mylogdata.txt. QUITTING.

I then used 
pi@MyOP:~ $ ncat localhost -u -l 10109 -o mylogdata.txt

but unfortunatly the mylogdata.txt file remains empty.

Has anyone a solution to my confusion? Thanks.

PS: Ultimately I hope to have one toggle icon (with kb short cut) in the task bar to start/stop recording.
Has anyone done this already?
  Reply
#2
can someone please test above on op 0.9.0 and report if it works.
I get always port in use error.

Thanks for help.
  Reply
#3
(03-23-2017, 02:55 AM)SkipperEarly Wrote: can someone please test above on op 0.9.0 and report if it works.
I get always port in use error.

Thanks for help.

Haven't tried ncat, and being still under 0.8, I am using kplex to record the nmea-sentences.
Add in .kplex.conf :

[file]
name=log
filename=/home/pi/kplexlogs/nmea.log
direction=out
append=yes
eol=n

works like a charme.
fair winds
Christian
  Reply
#4
Thanks Christian, that's a nice solution.
Will try it for a while and see how large the files gets. Thanks for the info.

What would be your suggestion for a simple way to switch on/off file recording? Stop kplex edit .kplex.conf restart kplex ? - I am sure there could be a simpler way.

fair winds _/)
  Reply
#5
(03-27-2017, 04:01 AM)SkipperEarly Wrote: Thanks Christian, that's a nice solution.
Will try it for a while and see how large the files gets. Thanks for the info.

What would be your suggestion for a simple way to switch on/off file recording? Stop kplex edit .kplex.conf restart kplex ? - I am sure there could be a simpler way.

fair winds _/)

You could start kplex wit the the option -f and specify two configuration files, one with logging enabled and the other without. So all it takes is to kill kplex and restart it with the other config file. But I don't know if this can be done with the openplotter interface - I am not very strong in python ...

glad to help
Christian
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)