• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] 0.14.4 compass calibration does nothing
#1
as above, under compass it detects my MPU-9250 I select heading and hit calibration, but nothing happens?
Am I missing something ?
  Reply
#2
any error on terminal?
  Reply
#3
I'm very new to this, how do I check that?
  Reply
#4
vapochilled: close the openplotter application, then reopen it through the drop down menu, Openplotter submenu. Choose Openplotter Debugging

Sailoog: I have the same issue clicking Calibrate button and nothing happens. I have STM LSM9DS0 IMU.

Traceback (most recent call last):
File "/home/pi/.config/openplotter/openplotter", line 1287, in on_calibration
subprocess.Popen('pypilot_calibration', cwd=self.home + '/.pypilot')
File "/usr/lib/python2.7/subprocess.py", line 710, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1335, in _execute_child
raise child_exception
OSError: [Errno 2] No such file or directory
  Reply
#5
thanks, I'm reloading in the hope it was a bad file? I'll try shortly and attempt to get the text

OK, I think it must have something to do with the bad dependencies
just did a fresh install and update, and it's now working properly, at least the calibration window now opens up.
  Reply
#6
It seems that your update attempt failed and there are not installed packages. Probably you come from a fresh 0.10.0 install. There was a solved issue that could be the cause of your failed update.

Try again. To force update when you are running the last one, type:


Code:
 /home/pi/.config/openplotter/update/update_OpenPlotter.sh
  Reply
#7
thank you, did a fresh update from 0.10.0, and it works, thanks for fixing the dependancies
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)