• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hanging when trying to start OpenPlotter when trying to use openGL
#1
OpenPlotter 0.14.4 alpha
OpenCPN 4.6.1
RPi3 (I've tried a few)
Various monitors
Kernel 4.9.35-v7+ #1014


I've had a complete nightmare to get openGL to work with my OpenPlotter set up. I see reports of people on the OpenCPN forum getting good glxgears frame rates with the latest 14.x release of OpenPlotter using openGL but try for the life of  me I cannot get it to work. All through my journey from 0.10 onwards (and before in fact) I have not got openGL to work.

In OpenCPN I go to Options>Advanced and select Use Accelerated Graphics (OpenGL)
In old raspi-config I select the Full KMS driver
My /boot/config.txt file now has the line inserted at the bottom:
dtoverlay=vc4-kms-v3d

But when I reboot, Openplotter tries to start and it hangs at "Check 800x480 display..." I then need to telnet in, edit the config.txt file and reboot.

What setting do other people use to get openGL to work? It's driving me bonkers and your help would be very much appreciated.

Interestingly if I substitute display800x480.py with a null replacement then OpenPlotter starts OK and the graphics does seem faster but OpenCPN then crashes if I resize the chart window.

Thanks
Chris

  Reply
#2
OpenGL in raspbian is still at experimental stage. I would like to spend time on this when a beta or stable stage is reached. Let us know if you make any progress please.
  Reply
#3
(08-09-2017, 10:27 AM)baltika_no_9 Wrote: OpenPlotter 0.14.4 alpha
OpenCPN 4.6.1
RPi3 (I've tried a few)
Various monitors
Kernel 4.9.35-v7+ #1014


I've had a complete nightmare to get openGL to work with my OpenPlotter set up. I see reports of people on the OpenCPN forum getting good glxgears frame rates with the latest 14.x release of OpenPlotter using openGL but try for the life of  me I cannot get it to work. All through my journey from 0.10 onwards (and before in fact) I have not got openGL to work.

In OpenCPN I go to Options>Advanced and select Use Accelerated Graphics (OpenGL)
In old raspi-config I select the Full KMS driver
My /boot/config.txt file now has the line inserted at the bottom:
dtoverlay=vc4-kms-v3d

But when I reboot, Openplotter tries to start and it hangs at "Check 800x480 display..." I then need to telnet in, edit the config.txt file and reboot.

What setting do other people use to get openGL to work? It's driving me bonkers and your help would be very much appreciated.

Interestingly if I substitute display800x480.py with a null replacement then OpenPlotter starts OK and the graphics does seem faster but OpenCPN then crashes if I resize the chart window.

Thanks
Chris



try instead
dtoverlay=vc4-fkms-v3d
  Reply
#4
Thanks Sean that helped me with the hanging and freezing a bit.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)