This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bidirectional TCP (or UDP) connection with Shipmodul Miniplex-3E
#1
I have openplotter updated on RPi3, on board I also have a Shipmodul Miniplex-3E that I use as hub / multiplex for nmea ports on cable.
I have set a TCP input on openplotter without problems so I have Openplotter the main multiplex with all the strings.
The Shipmodul (as it says in the manual) handles input and output together in the same connection so it can establish a bidirectional channel on the same port.
Openplotter does not allow to create a bidirectional TCP or UDP connection, and if I try to create two separately, it tells me that there is already a connection to that port.
How can I do? I would like to bring the Openplotter Compass to Shipmodul to have it on the nmea physical network.
I would not use usb-nmea adapters on Openplotter because I did not find them stable in my situation.
Thanks
  Reply
#2
The bidirectional NMEA0183 connection works.
I tested this configuration on kplex.conf:

[tcp]
name=sm
direction=both
optional=yes
mode=client
persist=yes
retry=10
address=192.168.8.3
port=10110
ifilter=+II***:-all
ofilter=+OC***:-all

If I put it in the GUI settings section, the openplotter recognizes it.
The diagnostic also visulizes input and output:
   

the edit window displays the settings but can not be changed because they would be rewritten incorrectly:
   

Even the Disable button can not be used because it changes the settings.

I think with a few changes to the software can be managed all properly, as is the case with kplex.
Smile
  Reply
#3
Good work kste. kplex is a versatile software but we need to keep openplotter simple for beginners. If we would have included all kplex features that would have been not possible. So we added the "advanced" option to directly editing the kplex.conf file. From your experience we can learn that we should improve the advanced integration. Personally I think we should not allow graphical edition for advanced parameters and show them as "advanced" label and open kplex.conf when you try to edit them graphically. I would try to keep the disable option at least. Thanks for reporting.

I will make this post sticky.
  Reply
#4
I just updated to OpenPlotter 0.17.1
One time configuration for my Miniplex-3USB: add new device in the 'USB manager' tab and add new serial input on port ttyUSB0 and 57600 baud
Manually after each reboot (and that is somewhat bothering): sudo stty -F /dev/ttyUSB0 460800
My previous attempts to bootstrap the stty command failed, somehow OpenPlotter overrules the places where I attempted to change.
Partly thanks to the high transfer rate of the multiplexer, I get 10hz compass course out of my 10y old Raymarine Fluxgate Smile
  Reply
#5
(09-19-2017, 04:07 AM)Sailoog Wrote: Good work kste. kplex is a versatile software but we need to keep openplotter simple for beginners. If we would have included all kplex features that would have been not possible. So we added the "advanced" option to directly editing the kplex.conf file. From your experience we can learn that we should improve the advanced integration. Personally I think we should not allow graphical edition for advanced parameters and show them as "advanced" label and open kplex.conf when you try to edit them graphically. I would try to keep the disable option at least. Thanks for reporting.

I will make this post sticky.

I'm struggling with the same issue. I have openplotter running on one PI (pi1) and on another PI (pi2) KPLEX is running. On Pi 1, I have my new (opto isolated) USB to 4 port serial interface connected getting GPS and Gyro on two serial ports. On Pi 2 I have a software running that uses a virtual serial port (PTY). I can send NMEA from openplotter to Kplex and the data is available on the virtual port, problem is that the NMEA that is send from the virtual port doesn't arrive at openplotter.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)