This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"SOLVED" BT gps antenna AMTEC
#1
I all,
this is my first time on this forum..
I've installed a gps BT antenna AMTEC on a RPI3 with BLUEZ on openPlotter 0.7.1, but no gps data in OpenCpn

some idea??

best regards


Attached Files Thumbnail(s)
                   
  Reply
#2
Hi 
try setting the baud rate to 4800
Ciao
Renato
  Reply
#3
Hi Renato,
it doesn't work at 4800 baud too

thanks

Mauro
  Reply
#4
you can only connect with one device to the gps.

try to shut off all other devices the gps was connected before.

bluetooth gps was is a little tricky. 
i will send you my solution. 
after adding this, 
the serial connection was well for me after every restart.
# sudo nano /etc/rc.local


add lines like this at the end with the MAC Adresses of your BT gps!

# bluetooth gps
rfcomm bind 0 00:15:4B:11:1A:95
#rfcomm bind 2 20:13:07:31:20:47
rfcomm bind 1 20:13:07:31:19:51
#rfcomm bind 3 00:15:4B:11:1A:95 

then the serial stream should get into the rfcomm device, test it with:

cat /dev/rfcomm0
  Reply
#5
(05-01-2016, 06:29 PM)holgerw Wrote: you can only connect with one device to the gps.

try to shut off all other devices the gps was connected before.

bluetooth gps was is a little tricky. 
i will send you my solution. 
after adding this, 
the serial connection was well for me after every restart.
# sudo nano /etc/rc.local


add lines like this at the end with the MAC Adresses of your BT gps!

# bluetooth gps
rfcomm bind 0 00:15:4B:11:1A:95
#rfcomm bind 2 20:13:07:31:20:47
rfcomm bind 1 20:13:07:31:19:51
#rfcomm bind 3 00:15:4B:11:1A:95 

then the serial stream should get into the rfcomm device, test it with:

cat /dev/rfcomm0

Hi, thanks a lot
Maybe I didn't understood!!!


I delete all the connection in openplotter setting and I add a new one for GPS BT
   

I tried to add those line


# bluetooth gps
rfcomm bind 0 00:02:C7:15:94:34
#rfcomm bind 2 00:02:C7:15:94:34
rfcomm bind 1 00:02:C7:15:94:34
#rfcomm bind 3 00:02:C7:15:94:34 


in 


sudo nano /etc/rc.local

   
   

But nothing happened

I tried also to add those line in open plotter advanced setting, but nothing happened...

   

I tried to give command "cat /dev/rfcomm0" before and after to give "sudo rfcomm connect 0 00:02:C7:15:94:34 &
   

I'm quite lost


Mauro
  Reply
#6
cepicscepics
in 


sudo nano /etc/rc.local




But nothing happened

I tried also to add those line in open plotter advanced setting, but nothing happened...



I tried to give command "cat /dev/rfcomm0" before and after to give "sudo rfcomm connect 0 00:02:C7:15:94:34 &



hi Mario - if you setup with sudo you must read the dev also with these rights:
sudo cat /dev/rfcomm0

make /dev/rfcomm0 readable for user pi
sudo chown pi /dev/rfcomm0
or
sudo chmod +r /dev/rfcomm0

Also you only need one dev/rfcommx linefor your gps, the others are examples from my setup.
delete your second /DEV/RFCOMM line in rc.local. the # Lines are comments.

also you dont need these lines in kplex.conf - normaly this is only an one shot setup after booting. (/etc/rc.local)
but user pi must be able to read  /dev/rfcomm0


good luck - Holger



 
  Reply
#7
(05-02-2016, 06:58 AM)holgerw Wrote: cepicscepics
in 


sudo nano /etc/rc.local




But nothing happened

I tried also to add those line in open plotter advanced setting, but nothing happened...



I tried to give command "cat /dev/rfcomm0" before and after to give "sudo rfcomm connect 0 00:02:C7:15:94:34 &



hi Mario - if you setup with sudo you must read the dev also with these rights:
sudo cat /dev/rfcomm0

make /dev/rfcomm0 readable for user pi
sudo chown pi /dev/rfcomm0
or
sudo chmod +r /dev/rfcomm0

Also you only need one dev/rfcommx linefor your gps, the others are examples from my setup.
delete your second /DEV/RFCOMM line in rc.local. the # Lines are comments.

also you dont need these lines in kplex.conf - normaly this is only an one shot setup after booting. (/etc/rc.local)
but user pi must be able to read  /dev/rfcomm0


good luck - Holger



 

thanks a lot for your patience


when I log in, if I try to type  sudo cat /dev/rfcomm0, noting happens..
   
   
   
if I type first 
sudo rfcomm connect 0 00:02:C7:15:94:34 &
   
   
and than 
sudo cat /dev/rfcomm0
the terminal start giving data but nothing on OpenCPN

now this is my File: /etc/rc.local 

   

and this my cleaned openplotter advanced setup

   

aiutoooo please

Mauro



 
  Reply
#8
cepicscepics
holgerwcepicscepics


If you bind you Bluetooth in /etc/rc.local to 1
THEN
you shoult read it in also in /dev/rfcomm1 and NOT rfcomm0
  Reply
#9
(05-02-2016, 10:57 AM)holgerw Wrote: cepicscepics
holgerwcepicscepics


If you bind you Bluetooth in /etc/rc.local to 1
THEN
you shoult read it in also in /dev/rfcomm1 and NOT rfcomm0

after boot, I open a terminal and I type:
sudo nano /etc/rc.local

I add this two line:
# bluetooth gps
rfcomm bind 1 00:02:C7:15:94:34

I save and exit

than I type:
sudo rfcomm connect 1 00:02:C7:15:94:34 &
the bluetooh icon became green

tan I type:
sudo cat /dev/rfcomm1
the terminal starts giving data
   

I close the terminal and I go in openplotter, I add a new serial imput on /dev/rfcomm1 at 4800 baud named gpsbt, I apply changes but nothing appens on OpenCPN
   
   

thanks a lot
  Reply
#10
If you have data in the terminal you are really close now.

Is OpenCPN listening to localhost 10110?

Do you have data in inspector window?
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)