This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Upgrade problem ?
#1
Hi, i decided to move from 0.8.0 to latest version to add a beta tester !

so I started with NOOBS, and asked to upgrade OP to latest, after a long long process I finished with a beatiful splash screen, applied the necessary setup but couldn't start OP, instead when lauching from terminal I get this :

Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
[Errno 111] Connection refused
Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
Traceback (most recent call last):
  File "/home/pi/.config/openplotter/openplotter", line 3535, in <module>
    MainFrame().Show()
  File "/home/pi/.config/openplotter/openplotter", line 224, in __init__
    self.page_sk()
  File "/home/pi/.config/openplotter/openplotter", line 2994, in page_sk
    response = requests.get('http://localhost:3000/signalk')
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 60, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 49, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 457, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 569, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/adapters.py", line 407, in send
    raise ConnectionError(err, request=request)
requests.exceptions.ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
pi@openplotter:~ $ [Errno 111] Connection refused
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#2
try to upgrade again from op tab sometimes it helps.
mare liberum
  Reply
#3
Hi Jim321,
The problem is that OP refuses to start ! I only get the splash screen (the anchor), and then : nothing !
Unless another suggestion, I'll try to re upgrade OP from the terminal ...
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#4
Could not launch update from command line (password issues) . Used the Restore (SHIFT KEY), and now relaunched OP update to beta version.
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#5
Sad 
(10-27-2017, 01:25 PM)Didier B Wrote: Could not launch update from command line (password issues) . Used the Restore (SHIFT KEY), and now relaunched OP update to beta version.
Oooops, failed again, impossible to start OP !

pi@openplotter:~ $ openplotter
Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
[Errno 111] Connection refused
Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
Traceback (most recent call last):
  File "/home/pi/.config/openplotter/openplotter", line 3535, in <module>
    MainFrame().Show()
  File "/home/pi/.config/openplotter/openplotter", line 224, in __init__
    self.page_sk()
  File "/home/pi/.config/openplotter/openplotter", line 2994, in page_sk
    response = requests.get('http://localhost:3000/signalk')
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 60, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 49, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 457, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 569, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/adapters.py", line 407, in send
    raise ConnectionError(err, request=request)
requests.exceptions.ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
pi@openplotter:~ $ [Errno 111] Connection refused
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#6
Sad 
Tried a 3rd time with a fresh noobs TF card (Samsung 32 Gb Evo U1 and raspberry Pi3)
Started from NOOBS, set locale and keyboard, then opened OP and selected update OP to beta
During the update, the process pauses with an awkward question asking to uninstall node.js y/N ?
I answerd 'N' in this 3rd attempt, thzn saw what looks as errors (many lines stating errnumber...) while the title in the terminal windows was NodeRED update ...
Same failure : after update to 0.16.0, OP won't start ...  it seems the update mechanism is broken !  Confused
 
Spent 3 days on the question, sadly folding back to old 0.8.0 ... Huh

BTW could you embark filezilla in OP, it is not a big load and really the best way to reload a lot of extras (charts, harmonic, board library, boats documents, etc. ).
(could not install in 0.16.0, neither with the menu, nor with the command line ...

Waiting for  a 0.16.0 (or 0.17.0 ?) noobs or (preferred) img.
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#7
If I can assume that you are using a fresh 0.10 Noobs copied to a freshly formatted card, then all should go automatically. You do need to answer yes to any question to allow the node.js update. As far as error messages during the update - yup they are there, but not to worry. It should all go through without a hitch.
  Reply
#8
(10-28-2017, 08:45 PM)waterman480 Wrote: If I can assume that you are using a fresh 0.10 Noobs copied to a freshly formatted card, then all should go automatically.  You do need to answer yes to any question to allow the node.js update.  As far as error messages during the update - yup they are there, but not to worry.  It should all go through without a hitch.
  • using a fresh 0.10 Noobs ........................................Yes, downloaded yesterday ;
  • copied to a freshly formatted card ..........................Yes, formated yesterday with SD Formater
  • You do need to answer yes to any question............That's what I did in my attempt n°2
  • It should all go through without a hitch....................Yes it should, but it didn't ! Huh

If someone can assure me he did this successfully since 30/10/2017, (-download Noobs 0.10.0 up to successful update to 0.16.0) I could go for a fourth attempt !
Btw the raspberry.org server seemed severely overloaded. Repeatedly, when accessing it, the update process 'froze' several times for very long period (ranging from 1/4 to 1/2 hour or more), and took a matter of hours (3-4) to come to its end at each of my 3 attempts....
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#9
(10-29-2017, 07:52 AM)Didier B Wrote: If someone can assure me he did this successfully since 30/10/2017, (-download Noobs 0.10.0 up to successful update to 0.16.0) I could go for a fourth attempt ! 
Btw the raspberry.org server seemed severely overloaded. Repeatedly, when accessing it, the update process 'froze' several times for very long period (ranging from 1/4 to 1/2 hour or more), and took a matter of hours (3-4) to come to its end at each of my 3 attempts....

Can't confirm since 30/10 but in the past it has sometimes taken a few attempts for the update to complete, I suspect it may be sensitive to the download speed. Sometimes on a mobile connection it seems to go through OK, other times not. Your timings sound about the same, hanging for what seems like forever as it compiles programs. Maybe even  longer than 3 - 4 hours total.
  Reply
#10
4t attemp, and 4th failure, freshly formatted card, fresh copy of Noobs ....



pi@openplotter:~ $ openplotter
Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
[Errno 111] Connection refused
Signal K starting
module.js:471
    throw err;
    ^

Error: Cannot find module 'express'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)formated
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/home/pi/.config/signalk-server-node/lib/index.js:22:15)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
[Errno 111] Connection refused
Traceback (most recent call last):
  File "/home/pi/.config/openplotter/openplotter", line 3535, in <module>
    MainFrame().Show()
  File "/home/pi/.config/openplotter/openplotter", line 224, in __init__
    self.page_sk()
  File "/home/pi/.config/openplotter/openplotter", line 2994, in page_sk
    response = requests.get('http://localhost:3000/signalk')
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 60, in get
    return request('get', url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/api.py", line 49, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 457, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/sessions.py", line 569, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/dist-packages/requests/adapters.py", line 407, in send
    raise ConnectionError(err, request=request)
requests.exceptions.ConnectionError: ('Connection aborted.', error(111, 'Connection refused'))
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)