This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Upgrade problem ?
#21
(11-12-2017, 08:57 AM)waterman480 Wrote: Having done this many times (and again on Friday), it appears that the problem is at your installation.  Bad internet, bad chip, bad power, or failure to allow to get to completion.  It also should take less than an hour, so perhaps your internet is the issue. 

I don't think so. My Internet is working quite well with exception of accessing Raspberry servers. I had no problem to install Stretch on a couple of Raspberry, though the access to the raspberry servers was long also, same as for the update & upgrade processes ...

The repetition of the same problem (around serverK) 6 times, after repeating 6 times the same process "by the book" excludes 'de facto' a mysterious random transitory fault in My Internet access, or in My power unit or in My power cable, or on My both RPis, or My four TF cards, may be  it is due to My Raspi box ...
Really, 40 years of experience as an electronics & IT engineer tell me this simply cannot be the case ...   Big Grin

Ah, and yes, I got the message "press Enter to reboot" - at the end of each of the 6 attempts !
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#22
if you lived in the US i would send you a sd card with it installed
mare liberum
  Reply
#23
Mysterious...

I am applying some changes just now, let me try a fresh 0.10.0 update after these changes
  Reply
#24
(11-19-2017, 08:05 AM)Sailoog Wrote: Mysterious...

I am applying some changes just now, let me try a fresh 0.10.0 update after these changes
  • Rolled back to 0.10.0 with shift key at startup ;
  • updated to 0.16.0 ;
  • Openplotter doesnt start due to SignalK ...
  • Re- installed Signalk-server-node (Thanks e Sailing !!!)  Smile
Code:
root@openplotter:/home/pi/.config# git clone https://github.com/signalk/signalk-server-node.git
Clonage dans 'signalk-server-node'...
remote: Counting objects: 3779, done.
remote: Compressing objects: 100% (46/46), done.
remote: Total 3779 (delta 52), reused 56 (delta 34), pack-reused 3699
Réception d'objets: 100% (3779/3779), 3.02 MiB | 984.00 KiB/s, fait.
Résolution des deltas: 100% (2483/2483), fait.
Vérification de la connectivité... fait.
root@openplotter:/home/pi/.config# cd signalk-server-node/
root@openplotter:/home/pi/.config/signalk-server-node# npm install
npm WARN deprecated object-keys@0.2.0: Please update to the latest object-keys
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN prefer global jsonlint@1.6.0 should be installed with -g
npm WARN prefer global jison@0.4.18 should be installed with -g

> sqlite3@3.1.13 install /home/pi/.config/signalk-server-node/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v3.1.13/node-v48-linux-arm.tar.gz
node-pre-gyp ERR! Pre-built binaries not found for sqlite3@3.1.13 and node@6.12.0 (node-v48 ABI) (falling back to source compile with node-gyp)
gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/6.12.0"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/tmp/.node-gyp"
make: Entering directory '/home/pi/.config/signalk-server-node/node_modules/sqlite3/build'
 ACTION deps_sqlite3_gyp_action_before_build_target_unpack_sqlite_dep Release/obj/gen/sqlite-autoconf-3150000/sqlite3.c
 TOUCH Release/obj.target/deps/action_before_build.stamp
 CC(target) Release/obj.target/sqlite3/gen/sqlite-autoconf-3150000/sqlite3.o
 AR(target) Release/obj.target/deps/sqlite3.a
 COPY Release/sqlite3.a
 CXX(target) Release/obj.target/node_sqlite3/src/database.o
../src/database.cc: In static member function ‘static void node_sqlite3::Database::Work_BeginOpen(node_sqlite3::Database::Baton*)’:
../src/database.cc:144:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),
        ^
../src/database.cc: In static member function ‘static void node_sqlite3::Database::Work_BeginClose(node_sqlite3::Database::Baton*)’:
../src/database.cc:230:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),
        ^
../src/database.cc: In static member function ‘static void node_sqlite3::Database::Work_BeginExec(node_sqlite3::Database::Baton*)’:
../src/database.cc:525:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),
        ^
../src/database.cc: In static member function ‘static void node_sqlite3::Database::Work_BeginLoadExtension(node_sqlite3::Database::Baton*)’:
../src/database.cc:625:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),
        ^
 CXX(target) Release/obj.target/node_sqlite3/src/node_sqlite3.o
 CXX(target) Release/obj.target/node_sqlite3/src/statement.o
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginPrepare(node_sqlite3::Database::Baton*)’:
../src/statement.cc:118:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),
        ^
In file included from ../src/statement.cc:6:0:
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginBind(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:322:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(Bind);
    ^
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginGet(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:370:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(Get);
    ^
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginRun(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:438:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(Run);
    ^
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginAll(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:504:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(All);
    ^
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginEach(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:601:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(Each);
    ^
../src/statement.cc: In static member function ‘static void node_sqlite3::Statement::Work_BeginReset(node_sqlite3::Statement::Baton*)’:
../src/macros.h:125:9: warning: unused variable ‘status’ [-Wunused-variable]
    int status = uv_queue_work(uv_default_loop(),                              \
        ^
../src/statement.cc:724:5: note: in expansion of macro ‘STATEMENT_BEGIN’
    STATEMENT_BEGIN(Reset);
    ^
 SOLINK_MODULE(target) Release/obj.target/node_sqlite3.node
 COPY Release/node_sqlite3.node
 COPY /home/pi/.config/signalk-server-node/node_modules/sqlite3/lib/binding/node-v48-linux-arm/node_sqlite3.node
 TOUCH Release/obj.target/action_after_build.stamp
make: Leaving directory '/home/pi/.config/signalk-server-node/node_modules/sqlite3/build'

> husky@0.14.3 install /home/pi/.config/signalk-server-node/node_modules/husky
> node ./bin/install.js

husky
setting up Git hooks
{ Error: EACCES: permission denied, open '/home/pi/.config/signalk-server-node/.git/hooks/applypatch-msg'
   at Error (native)
   at Object.fs.openSync (fs.js:642:18)
   at Object.fs.writeFileSync (fs.js:1356:33)
   at write (/home/pi/.config/signalk-server-node/node_modules/husky/src/install.js:17:6)
   at createHook (/home/pi/.config/signalk-server-node/node_modules/husky/src/install.js:46:5)
   at /home/pi/.config/signalk-server-node/node_modules/husky/src/install.js:81:21
   at Array.map (native)
   at installFrom (/home/pi/.config/signalk-server-node/node_modules/husky/src/install.js:77:10)
   at Object.<anonymous> (/home/pi/.config/signalk-server-node/node_modules/husky/bin/install.js:18:1)
   at Module._compile (module.js:570:32)
 errno: -13,
 code: 'EACCES',
 syscall: 'open',
 path: '/home/pi/.config/signalk-server-node/.git/hooks/applypatch-msg' }

> serialport@6.0.4 install /home/pi/.config/signalk-server-node/node_modules/serialport
> prebuild-install || node-gyp rebuild

prebuild-install info begin Prebuild-install version 2.3.0
prebuild-install info looking for local prebuild @ prebuilds/serialport-v6.0.4-node-v48-linux-arm.tar.gz
prebuild-install WARN install EACCES: permission denied, access '/root/.npm'
gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/6.12.0"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/tmp/.node-gyp"
make: Entering directory '/home/pi/.config/signalk-server-node/node_modules/serialport/build'
 CXX(target) Release/obj.target/serialport/src/serialport.o
 CXX(target) Release/obj.target/serialport/src/serialport_unix.o
 CXX(target) Release/obj.target/serialport/src/poller.o
 SOLINK_MODULE(target) Release/obj.target/serialport.node
 COPY Release/serialport.node
make: Leaving directory '/home/pi/.config/signalk-server-node/node_modules/serialport/build'
signalk-server@0.1.33 /home/pi/.config/signalk-server-node
├─┬ @mapbox/mbtiles@0.9.0
│ ├── @mapbox/sphericalmercator@1.0.5
│ ├── @mapbox/tiletype@0.3.1
│ ├── d3-queue@2.0.3
│ └─┬ sqlite3@3.1.13
│   └─┬ node-pre-gyp@0.6.38
│     ├─┬ hawk@3.1.3
│     │ ├── boom@2.10.1
│     │ ├── cryptiles@2.0.5
│     │ ├── hoek@2.16.3
│     │ └── sntp@1.0.9
│     ├─┬ mkdirp@0.5.1
│     │ └── minimist@0.0.8
│     ├─┬ nopt@4.0.1
│     │ ├── abbrev@1.1.1
│     │ └─┬ osenv@0.1.4
│     │   ├── os-homedir@1.0.2
│     │   └── os-tmpdir@1.0.2
│     ├─┬ npmlog@4.1.2
│     │ ├─┬ are-we-there-yet@1.1.4
│     │ │ └── delegates@1.0.0
│     │ ├── console-control-strings@1.1.0
│     │ ├─┬ gauge@2.7.4
│     │ │ ├── aproba@1.2.0
│     │ │ ├── has-unicode@2.0.1
│     │ │ ├── object-assign@4.1.1
│     │ │ ├── signal-exit@3.0.2
│     │ │ ├─┬ string-width@1.0.2
│     │ │ │ ├── code-point-at@1.1.0
│     │ │ │ └─┬ is-fullwidth-code-point@1.0.0
│     │ │ │   └── number-is-nan@1.0.1
│     │ │ ├─┬ strip-ansi@3.0.1
│     │ │ │ └── ansi-regex@2.1.1
│     │ │ └── wide-align@1.1.2
│     │ └── set-blocking@2.0.0
│     ├─┬ rc@1.2.1
│     │ ├── deep-extend@0.4.2
│     │ ├── ini@1.3.4
│     │ ├── minimist@1.2.0
│     │ └── strip-json-comments@2.0.1
│     ├─┬ request@2.81.0
│     │ ├── aws-sign2@0.6.0
│     │ ├── aws4@1.6.0
│     │ ├── caseless@0.12.0
│     │ ├─┬ combined-stream@1.0.5
│     │ │ └── delayed-stream@1.0.0
│     │ ├── extend@3.0.1
│     │ ├── forever-agent@0.6.1
│     │ ├─┬ form-data@2.1.4
│     │ │ └── asynckit@0.4.0
│     │ ├─┬ har-validator@4.2.1
│     │ │ ├─┬ ajv@4.11.8
│     │ │ │ ├── co@4.6.0
│     │ │ │ └─┬ json-stable-stringify@1.0.1
│     │ │ │   └── jsonify@0.0.0
│     │ │ └── har-schema@1.0.5
│     │ ├─┬ http-signature@1.1.1
│     │ │ ├── assert-plus@0.2.0
│     │ │ ├─┬ jsprim@1.4.1
│     │ │ │ ├── assert-plus@1.0.0
│     │ │ │ ├── extsprintf@1.3.0
│     │ │ │ ├── json-schema@0.2.3
│     │ │ │ └─┬ verror@1.10.0
│     │ │ │   └── assert-plus@1.0.0
│     │ │ └─┬ sshpk@1.13.1
│     │ │   ├── asn1@0.2.3
│     │ │   ├── assert-plus@1.0.0
│     │ │   ├── bcrypt-pbkdf@1.0.1
│     │ │   ├─┬ dashdash@1.14.1
│     │ │   │ └── assert-plus@1.0.0
│     │ │   ├── ecc-jsbn@0.1.1
│     │ │   ├─┬ getpass@0.1.7
│     │ │   │ └── assert-plus@1.0.0
│     │ │   ├── jsbn@0.1.1
│     │ │   └── tweetnacl@0.14.5
│     │ ├── is-typedarray@1.0.0
│     │ ├── isstream@0.1.2
│     │ ├── json-stringify-safe@5.0.1
│     │ ├─┬ mime-types@2.1.17
│     │ │ └── mime-db@1.30.0
│     │ ├── oauth-sign@0.8.2
│     │ ├── performance-now@0.2.0
│     │ ├── qs@6.4.0
│     │ ├── safe-buffer@5.1.1
│     │ ├── stringstream@0.0.5
│     │ ├─┬ tough-cookie@2.3.3
│     │ │ └── punycode@1.4.1
│     │ ├── tunnel-agent@0.6.0
│     │ └── uuid@3.1.0
│     ├─┬ rimraf@2.6.2
│     │ └─┬ glob@7.1.2
│     │   ├── fs.realpath@1.0.0
│     │   ├── inflight@1.0.6
│     │   ├─┬ minimatch@3.0.4
│     │   │ └─┬ brace-expansion@1.1.8
│     │   │   ├── balanced-match@1.0.0
│     │   │   └── concat-map@0.0.1
│     │   └── path-is-absolute@1.0.1
│     ├── semver@5.4.1
│     ├─┬ tar@2.2.1
│     │ ├── block-stream@0.0.9
│     │ ├─┬ fstream@1.0.11
│     │ │ └── graceful-fs@4.1.11
│     │ └── inherits@2.0.3
│     └─┬ tar-pack@3.4.0
│       ├─┬ debug@2.6.9
│       │ └── ms@2.0.0
│       ├── fstream-ignore@1.0.5
│       ├─┬ once@1.4.0
│       │ └── wrappy@1.0.2
│       ├─┬ readable-stream@2.3.3
│       │ ├── core-util-is@1.0.2
│       │ ├── isarray@1.0.0
│       │ ├── process-nextick-args@1.0.7
│       │ ├── string_decoder@1.0.3
│       │ └── util-deprecate@1.0.2
│       └── uid-number@0.0.6
├─┬ @signalk/aisreporter@0.0.3
│ ├── debug@2.6.9
│ └─┬ ggencoder@0.1.20
│   ├── async@2.6.0
│   └─┬ jison@0.4.18
│     ├─┬ cjson@0.3.0
│     │ └─┬ jsonlint@1.6.0
│     │   └── JSV@4.0.2
│     ├── ebnf-parser@0.1.10
│     ├─┬ escodegen@1.3.3
│     │ ├── estraverse@1.5.1
│     │ ├── esutils@1.0.0
│     │ └─┬ source-map@0.1.43
│     │   └── amdefine@1.0.1
│     ├── esprima@1.1.1
│     ├── jison-lex@0.3.4
│     ├── JSONSelect@0.4.0
│     ├── lex-parser@0.1.4
│     └─┬ nomnom@1.5.2
│       ├── colors@0.5.1
│       └── underscore@1.1.7
├─┬ @signalk/client@0.1.4
│ ├── bluebird@3.5.1
│ ├── eventemitter3@2.0.3
│ ├─┬ superagent@3.8.1
│ │ ├── component-emitter@1.2.1
│ │ ├── cookiejar@2.1.1
│ │ ├── formidable@1.1.1
│ │ ├── mime@1.6.0
│ │ └─┬ readable-stream@2.3.3
│ │   ├── core-util-is@1.0.2
│ │   ├── isarray@1.0.0
│ │   ├── process-nextick-args@1.0.7
│ │   ├── string_decoder@1.0.3
│ │   └── util-deprecate@1.0.2
│ ├── superagent-promise@1.1.0
│ └─┬ url@0.11.0
│   ├── punycode@1.3.2
│   └── querystring@0.2.0
├── @signalk/freeboard-sk@0.0.1
├── @signalk/instrumentpanel@0.2.3
├── @signalk/maptracker@0.0.2  extraneous (git+https://github.com/signalk/maptracker.git#b3775c77998faa35cf2de8b6f10e07e47639e854)
├─┬ @signalk/n2k-signalk@0.0.6
│ └─┬ JSONStream@1.3.1
│   └── jsonparse@1.3.1
├─┬ @signalk/nmea0183-signalk@2.1.0
│ ├── @signalk/nmea0183-utilities@0.4.0
│ └── moment-timezone@0.5.14
├── @signalk/sailgauge@1.1.0
├─┬ @signalk/signalk-schema@0.0.1-12
│ ├── debug@2.6.9
│ ├─┬ json-schema-ref-parser@3.3.1
│ │ ├── call-me-maybe@1.0.1
│ │ ├── es6-promise@4.1.1
│ │ ├─┬ js-yaml@3.10.0
│ │ │ ├─┬ argparse@1.0.9
│ │ │ │ └── sprintf-js@1.0.3
│ │ │ └── esprima@4.0.0
│ │ ├─┬ ono@4.0.2
│ │ │ └── format-util@1.0.3
│ │ └─┬ z-schema@3.19.0
│ │   ├── lodash.get@4.4.2
│ │   ├── lodash.isequal@4.5.0
│ │   └── validator@9.1.2
│ ├─┬ JSONStream@0.7.4
│ │ └── jsonparse@0.0.5
│ ├── lodash@3.10.1
│ ├── tv4@1.3.0
│ └─┬ tv4-formats@2.2.2
│   └── validator@7.2.0
├── @signalk/signalk-to-nmea0183@0.0.1  invalid (git+https://github.com/signalk/signalk-to-nmea0183.git#62833649d810f1944c455142fa56d9eda964ba12)
├── @signalk/simplegauges@1.0.1
├── baconjs@0.7.95
├─┬ body-parser@1.18.2
│ ├── bytes@3.0.0
│ ├── content-type@1.0.4
│ ├── debug@2.6.9
│ ├── depd@1.1.1
│ ├─┬ http-errors@1.6.2
│ │ ├── inherits@2.0.3
│ │ ├── setprototypeof@1.0.3
│ │ └── statuses@1.4.0
│ ├── iconv-lite@0.4.19
│ ├─┬ on-finished@2.3.0
│ │ └── ee-first@1.1.1
│ ├── qs@6.5.1
│ ├─┬ raw-body@2.3.2
│ │ └── unpipe@1.0.0
│ └─┬ type-is@1.6.15
│   └── media-typer@0.3.0
├─┬ chai@4.1.2
│ ├── assertion-error@1.0.2
│ ├── check-error@1.0.2
│ ├── deep-eql@3.0.1
│ ├── get-func-name@2.0.0
│ ├── pathval@1.1.0
│ └── type-detect@4.0.5
├── chai-things@0.2.0
├── colors@1.1.2
├── compare-versions@3.1.0
├─┬ cors@2.8.4
│ ├── object-assign@4.1.1
│ └── vary@1.1.2
├─┬ debug@3.1.0
│ └── ms@2.0.0
├── deep-get-set@1.1.0
├── dev-null-stream@0.0.1
├─┬ ejson@2.1.2
│ └── underscore@1.8.3
├─┬ errorhandler@1.5.0
│ ├─┬ accepts@1.3.4
│ │ └── negotiator@0.6.1
│ └── escape-html@1.0.3
├─┬ express@4.16.2
│ ├── array-flatten@1.1.1
│ ├── content-disposition@0.5.2
│ ├── cookie@0.3.1
│ ├── cookie-signature@1.0.6
│ ├── debug@2.6.9
│ ├── encodeurl@1.0.1
│ ├── etag@1.8.1
│ ├─┬ finalhandler@1.1.0
│ │ ├── debug@2.6.9
│ │ └── statuses@1.3.1
│ ├── fresh@0.5.2
│ ├── merge-descriptors@1.0.1
│ ├── methods@1.1.2
│ ├── parseurl@1.3.2
│ ├── path-to-regexp@0.1.7
│ ├─┬ proxy-addr@2.0.2
│ │ ├── forwarded@0.1.2
│ │ └── ipaddr.js@1.5.2
│ ├── range-parser@1.2.0
│ ├── safe-buffer@5.1.1
│ ├─┬ send@0.16.1
│ │ ├── debug@2.6.9
│ │ ├── destroy@1.0.4
│ │ ├── mime@1.4.1
│ │ └── statuses@1.3.1
│ ├── serve-static@1.13.1
│ ├── setprototypeof@1.1.0
│ ├── statuses@1.3.1
│ └── utils-merge@1.0.1
├─┬ express-namespace@0.1.1
│ └── methods@0.0.1
├─┬ file-timestamp-stream@0.0.4
│ └── ultra-strftime@1.0.2
├── flatmap@0.0.3
├── freeport-promise@1.1.0
├─┬ github-changes@1.1.1
│ ├── bluebird@1.0.3
│ ├─┬ ghauth@3.0.0
│ │ ├─┬ application-config@0.1.2
│ │ │ └── application-config-path@0.1.0
│ │ ├─┬ bl@0.9.5
│ │ │ └─┬ readable-stream@1.0.34
│ │ │   ├── isarray@0.0.1
│ │ │   └── string_decoder@0.10.31
│ │ ├─┬ hyperquest@1.2.0
│ │ │ ├─┬ duplexer2@0.0.2
│ │ │ │ └─┬ readable-stream@1.1.14
│ │ │ │   ├── isarray@0.0.1
│ │ │ │   └── string_decoder@0.10.31
│ │ │ └─┬ through2@0.6.5
│ │ │   └─┬ readable-stream@1.0.34
│ │ │     ├── isarray@0.0.1
│ │ │     └── string_decoder@0.10.31
│ │ ├─┬ read@1.0.7
│ │ │ └── mute-stream@0.0.7
│ │ └── xtend@4.0.1
│ ├── github@0.1.16
│ ├─┬ github-commit-stream@0.1.0
│ │ ├── async@0.2.10
│ │ └─┬ request@2.22.0
│ │   ├── aws-sign@0.3.0
│ │   ├── cookie-jar@0.3.0
│ │   ├── forever-agent@0.5.2
│ │   ├─┬ form-data@0.0.8
│ │   │ └─┬ combined-stream@0.0.7
│ │   │   └── delayed-stream@0.0.5
│ │   ├─┬ hawk@0.13.1
│ │   │ ├─┬ boom@0.4.2
│ │   │ │ └── hoek@0.9.1
│ │   │ ├── cryptiles@0.2.2
│ │   │ ├── hoek@0.8.5
│ │   │ └─┬ sntp@0.2.4
│ │   │   └── hoek@0.9.1
│ │   ├─┬ http-signature@0.10.1
│ │   │ ├── asn1@0.1.11
│ │   │ ├── assert-plus@0.1.5
│ │   │ └── ctype@0.5.3
│ │   ├── json-stringify-safe@4.0.0
│ │   ├── mime@1.2.11
│ │   ├── node-uuid@1.4.8
│ │   ├── oauth-sign@0.3.0
│ │   ├── qs@0.6.6
│ │   └── tunnel-agent@0.3.0
│ ├── lodash@2.4.1
│ ├── moment-timezone@0.5.5
│ ├─┬ nomnom@1.6.2
│ │ ├── colors@0.5.1
│ │ └── underscore@1.4.4
│ ├─┬ parse-link-header@0.1.0
│ │ └─┬ xtend@2.0.6
│ │   ├── is-object@0.1.2
│ │   └─┬ object-keys@0.2.0
│ │     ├── foreach@2.0.5
│ │     ├── indexof@0.0.1
│ │     └── is@0.2.7
│ └── semver@2.2.1
├─┬ husky@0.14.3
│ ├─┬ is-ci@1.0.10
│ │ └── ci-info@1.1.2
│ ├── normalize-path@1.0.0
│ └── strip-indent@2.0.0
├─┬ lint-staged@5.0.0
│ ├── app-root-path@2.0.1
│ ├─┬ chalk@2.3.0
│ │ ├─┬ ansi-styles@3.2.0
│ │ │ └─┬ color-convert@1.9.1
│ │ │   └── color-name@1.1.3
│ │ └── supports-color@4.5.0
│ ├── commander@2.12.1
│ ├─┬ cosmiconfig@3.1.0
│ │ ├── is-directory@0.3.1
│ │ ├─┬ parse-json@3.0.0
│ │ │ └─┬ error-ex@1.3.1
│ │ │   └── is-arrayish@0.2.1
│ │ └── require-from-string@2.0.1
│ ├── dedent@0.7.0
│ ├─┬ execa@0.8.0
│ │ ├─┬ cross-spawn@5.1.0
│ │ │ ├─┬ lru-cache@4.1.1
│ │ │ │ ├── pseudomap@1.0.2
│ │ │ │ └── yallist@2.1.2
│ │ │ └─┬ shebang-command@1.2.0
│ │ │   └── shebang-regex@1.0.0
│ │ ├── get-stream@3.0.0
│ │ ├─┬ npm-run-path@2.0.2
│ │ │ └── path-key@2.0.1
│ │ ├── p-finally@1.0.0
│ │ ├── signal-exit@3.0.2
│ │ └── strip-eof@1.0.0
│ ├── find-parent-dir@0.3.0
│ ├─┬ is-glob@4.0.0
│ │ └── is-extglob@2.1.1
│ ├─┬ jest-validate@21.2.1
│ │ ├── jest-get-type@21.2.0
│ │ ├── leven@2.1.0
│ │ └─┬ pretty-format@21.2.1
│ │   └── ansi-regex@3.0.0
│ ├─┬ listr@0.13.0
│ │ ├─┬ chalk@1.1.3
│ │ │ ├── ansi-styles@2.2.1
│ │ │ └── supports-color@2.0.0
│ │ ├─┬ cli-truncate@0.2.1
│ │ │ ├── slice-ansi@0.0.4
│ │ │ └─┬ string-width@1.0.2
│ │ │   ├── code-point-at@1.1.0
│ │ │   └─┬ is-fullwidth-code-point@1.0.0
│ │ │     └── number-is-nan@1.0.1
│ │ ├── figures@1.7.0
│ │ ├─┬ indent-string@2.1.0
│ │ │ └─┬ repeating@2.0.1
│ │ │   └── is-finite@1.0.2
│ │ ├─┬ is-observable@0.2.0
│ │ │ └── symbol-observable@0.2.4
│ │ ├── is-promise@2.1.0
│ │ ├── listr-silent-renderer@1.1.1
│ │ ├─┬ listr-update-renderer@0.4.0
│ │ │ ├─┬ chalk@1.1.3
│ │ │ │ ├── ansi-styles@2.2.1
│ │ │ │ └── supports-color@2.0.0
│ │ │ ├── elegant-spinner@1.0.1
│ │ │ ├── indent-string@3.2.0
│ │ │ └── log-symbols@1.0.2
│ │ ├─┬ listr-verbose-renderer@0.4.1
│ │ │ ├─┬ chalk@1.1.3
│ │ │ │ ├── ansi-styles@2.2.1
│ │ │ │ └── supports-color@2.0.0
│ │ │ ├─┬ cli-cursor@1.0.2
│ │ │ │ └─┬ restore-cursor@1.0.1
│ │ │ │   ├── exit-hook@1.1.1
│ │ │ │   └── onetime@1.1.0
│ │ │ └── date-fns@1.29.0
│ │ ├── log-symbols@1.0.2
│ │ ├─┬ log-update@1.0.2
│ │ │ └── ansi-escapes@1.4.0
│ │ ├─┬ ora@0.2.3
│ │ │ ├─┬ chalk@1.1.3
│ │ │ │ ├── ansi-styles@2.2.1
│ │ │ │ └── supports-color@2.0.0
│ │ │ └── cli-spinners@0.1.2
│ │ ├─┬ stream-to-observable@0.2.0
│ │ │ └── any-observable@0.2.0
│ │ └─┬ strip-ansi@3.0.1
│ │   └── ansi-regex@2.1.1
│ ├── log-symbols@2.1.0
│ ├─┬ minimatch@3.0.4
│ │ └─┬ brace-expansion@1.1.8
│ │   ├── balanced-match@1.0.0
│ │   └── concat-map@0.0.1
│ ├─┬ npm-which@3.0.1
│ │ └── npm-path@2.0.3
│ ├── p-map@1.2.0
│ ├── path-is-inside@1.0.2
│ ├── pify@3.0.0
│ ├── staged-git-files@0.0.4
│ └─┬ stringify-object@3.2.1
│   ├── get-own-enumerable-property-symbols@2.0.1
│   ├── is-obj@1.0.1
│   └── is-regexp@1.0.0
├── lodash@4.17.4
├── minimist@1.2.0
├─┬ mocha@4.0.1
│ ├── browser-stdout@1.3.0
│ ├── commander@2.11.0
│ ├── diff@3.3.1
│ ├── escape-string-regexp@1.0.5
│ ├─┬ glob@7.1.2
│ │ ├── fs.realpath@1.0.0
│ │ ├─┬ inflight@1.0.6
│ │ │ └── wrappy@1.0.2
│ │ ├── once@1.4.0
│ │ └── path-is-absolute@1.0.1
│ ├── growl@1.10.3
│ ├── he@1.1.1
│ ├─┬ mkdirp@0.5.1
│ │ └── minimist@0.0.8
│ └─┬ supports-color@4.4.0
│   └── has-flag@2.0.0
├── moment@2.19.2
├─┬ morgan@1.9.0
│ ├── basic-auth@2.0.0
│ ├── debug@2.6.9
│ └── on-headers@1.0.1
├─┬ node-fetch@1.7.3
│ ├── encoding@0.1.12
│ └── is-stream@1.1.0
├── node-gpsd@0.3.0
├─┬ pem@1.12.3
│ ├─┬ md5@2.2.1
│ │ ├── charenc@0.0.2
│ │ ├── crypt@0.0.2
│ │ └── is-buffer@1.1.6
│ ├── os-tmpdir@1.0.2
│ └─┬ which@1.3.0
│   └── isexe@2.0.0
├─┬ prettier-standard@7.0.3
│ ├── @sheerun/eslint-config-standard@10.2.1
│ ├─┬ babel-eslint@8.0.2
│ │ ├─┬ @babel/code-frame@7.0.0-beta.32
│ │ │ ├── esutils@2.0.2
│ │ │ └── js-tokens@3.0.2
│ │ ├─┬ @babel/traverse@7.0.0-beta.32
│ │ │ ├─┬ @babel/helper-function-name@7.0.0-beta.32
│ │ │ │ ├── @babel/helper-get-function-arity@7.0.0-beta.32
│ │ │ │ └── @babel/template@7.0.0-beta.32
│ │ │ ├── globals@10.4.0
│ │ │ └─┬ invariant@2.2.2
│ │ │   └── loose-envify@1.3.1
│ │ ├─┬ @babel/types@7.0.0-beta.32
│ │ │ ├── esutils@2.0.2
│ │ │ └── to-fast-properties@2.0.0
│ │ └── babylon@7.0.0-beta.32
│ ├─┬ babel-runtime@6.26.0
│ │ ├── core-js@2.5.1
│ │ └── regenerator-runtime@0.11.0
│ ├─┬ chalk@1.1.3
│ │ ├── ansi-styles@2.2.1
│ │ ├── has-ansi@2.0.0
│ │ └── supports-color@2.0.0
│ ├─┬ eslint@4.12.0
│ │ ├─┬ ajv@5.5.0
│ │ │ ├── co@4.6.0
│ │ │ ├── fast-deep-equal@1.0.0
│ │ │ ├── fast-json-stable-stringify@2.0.0
│ │ │ └── json-schema-traverse@0.3.1
│ │ ├─┬ babel-code-frame@6.26.0
│ │ │ ├─┬ chalk@1.1.3
│ │ │ │ ├── ansi-styles@2.2.1
│ │ │ │ └── supports-color@2.0.0
│ │ │ └── esutils@2.0.2
│ │ ├─┬ concat-stream@1.6.0
│ │ │ └── typedarray@0.0.6
│ │ ├─┬ doctrine@2.0.2
│ │ │ └── esutils@2.0.2
│ │ ├─┬ eslint-scope@3.7.1
│ │ │ ├─┬ esrecurse@4.2.0
│ │ │ │ └── estraverse@4.2.0
│ │ │ └── estraverse@4.2.0
│ │ ├─┬ espree@3.5.2
│ │ │ ├── acorn@5.2.1
│ │ │ └─┬ acorn-jsx@3.0.1
│ │ │   └── acorn@3.3.0
│ │ ├─┬ esquery@1.0.0
│ │ │ └── estraverse@4.2.0
│ │ ├── estraverse@4.2.0
│ │ ├── esutils@2.0.2
│ │ ├─┬ file-entry-cache@2.0.0
│ │ │ └─┬ flat-cache@1.3.0
│ │ │   ├── circular-json@0.3.3
│ │ │   ├─┬ del@2.2.2
│ │ │   │ ├─┬ globby@5.0.0
│ │ │   │ │ ├─┬ array-union@1.0.2
│ │ │   │ │ │ └── array-uniq@1.0.3
│ │ │   │ │ ├── arrify@1.0.1
│ │ │   │ │ └── pify@2.3.0
│ │ │   │ ├── is-path-cwd@1.0.0
│ │ │   │ ├─┬ is-path-in-cwd@1.0.0
│ │ │   │ │ └── is-path-inside@1.0.0
│ │ │   │ ├── pify@2.3.0
│ │ │   │ └── rimraf@2.6.2
│ │ │   ├── graceful-fs@4.1.11
│ │ │   └── write@0.2.1
│ │ ├── functional-red-black-tree@1.0.1
│ │ ├── globals@11.0.1
│ │ ├── imurmurhash@0.1.4
│ │ ├─┬ inquirer@3.3.0
│ │ │ ├── ansi-escapes@3.0.0
│ │ │ ├─┬ cli-cursor@2.1.0
│ │ │ │ └─┬ restore-cursor@2.0.0
│ │ │ │   └─┬ onetime@2.0.1
│ │ │ │     └── mimic-fn@1.1.0
│ │ │ ├── cli-width@2.2.0
│ │ │ ├─┬ external-editor@2.1.0
│ │ │ │ ├── chardet@0.4.2
│ │ │ │ └── tmp@0.0.33
│ │ │ ├── figures@2.0.0
│ │ │ ├── run-async@2.3.0
│ │ │ ├── rx-lite@4.0.8
│ │ │ ├── rx-lite-aggregates@4.0.8
│ │ │ ├─┬ string-width@2.1.1
│ │ │ │ └── is-fullwidth-code-point@2.0.0
│ │ │ └─┬ strip-ansi@4.0.0
│ │ │   └── ansi-regex@3.0.0
│ │ ├─┬ is-resolvable@1.0.0
│ │ │ └── tryit@1.0.3
│ │ ├── json-stable-stringify-without-jsonify@1.0.1
│ │ ├─┬ levn@0.3.0
│ │ │ ├── prelude-ls@1.1.2
│ │ │ └── type-check@0.3.2
│ │ ├── natural-compare@1.4.0
│ │ ├─┬ optionator@0.8.2
│ │ │ ├── deep-is@0.1.3
│ │ │ ├── fast-levenshtein@2.0.6
│ │ │ └── wordwrap@1.0.0
│ │ ├── pluralize@7.0.0
│ │ ├── progress@2.0.0
│ │ ├─┬ require-uncached@1.0.3
│ │ │ ├─┬ caller-path@0.1.0
│ │ │ │ └── callsites@0.2.0
│ │ │ └── resolve-from@1.0.1
│ │ ├── semver@5.4.1
│ │ ├─┬ strip-ansi@4.0.0
│ │ │ └── ansi-regex@3.0.0
│ │ ├── strip-json-comments@2.0.1
│ │ ├─┬ table@4.0.2
│ │ │ ├── ajv-keywords@2.1.1
│ │ │ ├─┬ slice-ansi@1.0.0
│ │ │ │ └── is-fullwidth-code-point@2.0.0
│ │ │ └─┬ string-width@2.1.1
│ │ │   └─┬ strip-ansi@4.0.0
│ │ │     └── ansi-regex@3.0.0
│ │ └── text-table@0.2.0
│ ├─┬ find-up@2.1.0
│ │ └─┬ locate-path@2.0.0
│ │   ├─┬ p-locate@2.0.0
│ │   │ └── p-limit@1.1.0
│ │   └── path-exists@3.0.0
│ ├── get-stdin@5.0.1
│ ├── ignore@3.3.7
│ ├── indent-string@3.2.0
│ ├── lodash.memoize@4.1.2
│ ├─┬ loglevel-colored-level-prefix@1.0.0
│ │ ├─┬ chalk@1.1.3
│ │ │ ├── ansi-styles@2.2.1
│ │ │ └── supports-color@2.0.0
│ │ └── loglevel@1.6.0
│ ├─┬ meow@3.7.0
│ │ ├─┬ camelcase-keys@2.1.0
│ │ │ └── camelcase@2.1.1
│ │ ├── decamelize@1.2.0
│ │ ├─┬ loud-rejection@1.6.0
│ │ │ └─┬ currently-unhandled@0.4.1
│ │ │   └── array-find-index@1.0.2
│ │ ├── map-obj@1.0.1
│ │ ├─┬ normalize-package-data@2.4.0
│ │ │ ├── hosted-git-info@2.5.0
│ │ │ ├─┬ is-builtin-module@1.0.0
│ │ │ │ └── builtin-modules@1.1.1
│ │ │ └─┬ validate-npm-package-license@3.0.1
│ │ │   ├─┬ spdx-correct@1.0.2
│ │ │   │ └── spdx-license-ids@1.2.2
│ │ │   └── spdx-expression-parse@1.0.4
│ │ ├─┬ read-pkg-up@1.0.1
│ │ │ ├─┬ find-up@1.1.2
│ │ │ │ ├── path-exists@2.1.0
│ │ │ │ └─┬ pinkie-promise@2.0.1
│ │ │ │   └── pinkie@2.0.4
│ │ │ └─┬ read-pkg@1.1.0
│ │ │   ├─┬ load-json-file@1.1.0
│ │ │   │ ├── parse-json@2.2.0
│ │ │   │ ├── pify@2.3.0
│ │ │   │ └─┬ strip-bom@2.0.0
│ │ │   │   └── is-utf8@0.2.1
│ │ │   └─┬ path-type@1.1.0
│ │ │     └── pify@2.3.0
│ │ ├─┬ redent@1.0.0
│ │ │ └─┬ strip-indent@1.0.1
│ │ │   └── get-stdin@4.0.1
│ │ └── trim-newlines@1.0.0
│ ├─┬ messageformat@1.1.0
│ │ ├── glob@7.0.6
│ │ ├── make-plural@4.1.1
│ │ ├── messageformat-parser@1.1.0
│ │ ├─┬ nopt@3.0.6
│ │ │ └── abbrev@1.1.1
│ │ └── reserved-words@0.1.2
│ ├── prettier@1.7.4
│ ├─┬ prettier-eslint@8.2.2
│ │ ├── common-tags@1.5.1
│ │ ├── dlv@1.1.0
│ │ ├── indent-string@3.2.0
│ │ ├── lodash.merge@4.6.0
│ │ ├── pretty-format@20.0.3
│ │ ├── require-relative@0.8.7
│ │ ├── typescript@2.6.2
│ │ └─┬ typescript-eslint-parser@8.0.1
│ │   └── lodash.unescape@4.0.1
│ └─┬ rxjs@5.5.2
│   └── symbol-observable@1.0.4
├─┬ primus@7.1.0
│ ├─┬ access-control@1.0.0
│ │ └── millisecond@0.1.2
│ ├── asyncemit@3.0.1
│ ├─┬ create-server@1.0.1
│ │ └── connected@0.0.2
│ ├─┬ diagnostics@1.1.0
│ │ ├─┬ colorspace@1.0.1
│ │ │ ├─┬ color@0.8.0
│ │ │ │ ├── color-convert@0.5.3
│ │ │ │ └── color-string@0.3.0
│ │ │ └── text-hex@0.0.0
│ │ ├─┬ enabled@1.0.2
│ │ │ └── env-variable@0.0.3
│ │ └─┬ kuler@0.0.0
│ │   └── colornames@0.0.2
│ ├── forwarded-for@1.0.1
│ ├─┬ fusing@1.0.0
│ │ ├── emits@3.0.0
│ │ └─┬ predefine@0.1.2
│ │   └── extendible@0.1.1
│ ├─┬ setheader@0.0.4
│ │ └── debug@0.7.4
│ ├── ultron@1.1.1
│ └── yeast@0.1.2
├─┬ request@2.83.0
│ ├── aws-sign2@0.7.0
│ ├── aws4@1.6.0
│ ├── caseless@0.12.0
│ ├─┬ combined-stream@1.0.5
│ │ └── delayed-stream@1.0.0
│ ├── extend@3.0.1
│ ├── forever-agent@0.6.1
│ ├─┬ form-data@2.3.1
│ │ └── asynckit@0.4.0
│ ├─┬ har-validator@5.0.3
│ │ └── har-schema@2.0.0
│ ├─┬ hawk@6.0.2
│ │ ├── boom@4.3.1
│ │ ├─┬ cryptiles@3.1.2
│ │ │ └── boom@5.2.0
│ │ ├── hoek@4.2.0
│ │ └── sntp@2.1.0
│ ├─┬ http-signature@1.2.0
│ │ ├── assert-plus@1.0.0
│ │ ├─┬ jsprim@1.4.1
│ │ │ ├── assert-plus@1.0.0
│ │ │ ├── extsprintf@1.3.0
│ │ │ ├── json-schema@0.2.3
│ │ │ └─┬ verror@1.10.0
│ │ │   └── assert-plus@1.0.0
│ │ └─┬ sshpk@1.13.1
│ │   ├── asn1@0.2.3
│ │   ├── assert-plus@1.0.0
│ │   ├── bcrypt-pbkdf@1.0.1
│ │   ├─┬ dashdash@1.14.1
│ │   │ └── assert-plus@1.0.0
│ │   ├── ecc-jsbn@0.1.1
│ │   ├─┬ getpass@0.1.7
│ │   │ └── assert-plus@1.0.0
│ │   ├── jsbn@0.1.1
│ │   └── tweetnacl@0.14.5
│ ├── is-typedarray@1.0.0
│ ├── isstream@0.1.2
│ ├── json-stringify-safe@5.0.1
│ ├─┬ mime-types@2.1.17
│ │ └── mime-db@1.30.0
│ ├── oauth-sign@0.8.2
│ ├── performance-now@2.1.0
│ ├── stringstream@0.0.5
│ ├─┬ tough-cookie@2.3.3
│ │ └── punycode@1.4.1
│ ├── tunnel-agent@0.6.0
│ └── uuid@3.1.0
├─┬ request-promise@4.2.2
│ ├── request-promise-core@1.1.1
│ └── stealthy-require@1.1.1
├─┬ serialport@6.0.4
│ ├── bindings@1.3.0
│ ├── nan@2.7.0
│ ├─┬ prebuild-install@2.3.0
│ │ ├── expand-template@1.1.0
│ │ ├── github-from-package@0.0.0
│ │ ├── node-abi@2.1.2
│ │ ├── noop-logger@0.1.1
│ │ ├─┬ npmlog@4.1.2
│ │ │ ├─┬ are-we-there-yet@1.1.4
│ │ │ │ └── delegates@1.0.0
│ │ │ ├── console-control-strings@1.1.0
│ │ │ ├─┬ gauge@2.7.4
│ │ │ │ ├── aproba@1.2.0
│ │ │ │ ├── has-unicode@2.0.1
│ │ │ │ └── wide-align@1.1.2
│ │ │ └── set-blocking@2.0.0
│ │ ├── os-homedir@1.0.2
│ │ ├─┬ pump@1.0.3
│ │ │ └── end-of-stream@1.4.0
│ │ ├─┬ rc@1.2.2
│ │ │ ├── deep-extend@0.4.2
│ │ │ └── ini@1.3.5
│ │ ├─┬ simple-get@1.4.3
│ │ │ └── unzip-response@1.0.2
│ │ └─┬ tar-fs@1.16.0
│ │   ├── chownr@1.0.1
│ │   └─┬ tar-stream@1.5.5
│ │     └── bl@1.2.1
│ └── promirepl@1.0.1
├── set-system-time@1.0.0  (git+https://github.com/tkurki/set-system-time.git#691d33a6272e768692e7849d258d408b8dcf25c1)
├── signalk-playground@0.0.1  (git+https://github.com/signalk/playground.git#85a175fe930153d9e2e5f950535e2562cee8bc93)
├─┬ signalk-zones@0.0.1  (git+https://github.com/signalk/signalk-zones.git#e8a4e738e73f8ed89abfce9214839c7047966f3d)
│ └─┬ @signalk/signalk-schema@0.0.1-6
│   ├── debug@2.6.9
│   ├─┬ JSONStream@0.7.4
│   │ └── jsonparse@0.0.5
│   └── lodash@3.10.1
├── split@1.0.1
├── stat-mode@0.2.2
├─┬ stream-throttle@0.1.3
│ └── limiter@1.1.2
├── through@2.3.8
├─┬ ws@3.3.2
│ └── async-limiter@1.0.0
└─┬ xml2js@0.4.19
 ├── sax@1.2.4
 └── xmlbuilder@9.0.4
  • and NOW, YES, Openplotter can start !
  • If the situation stabilises this issue will be 'walked around'. Well, if the update could include the proper version of signalk-server-node it would be totally solved !
  • A big THANKS to all helpers,  and a special one for Sailoog ! Smile Smile
Edited 28/11/2017 10h32 CET :     My installation of 0.16.0 seems stable, I change the post title to solved (almost) !
Config : RPi 3, OP 1.1
Cordialement
Didier B





  Reply
#25
Had to update from 0.10 to latest stabil 0.17.1 and got same symptoms: only splash then
pi@op010:~ $ openplotter
Traceback (most recent call last):
File "/home/pi/.config/openplotter/openplotter", line 3539, in <module>
MainFrame().Show()
File "/home/pi/.config/openplotter/openplotter", line 254, in __init__
self.read_i2c()
File "/home/pi/.config/openplotter/openplotter", line 1899, in read_i2c
self.list_i2c.Append([str©, name, address, magn_list[c], iii[0], str(iii[1]), str(iii[2])])
UnboundLocalError: local variable 'magn_list' referenced before assignment

followed the advise earlier but to no joy.
Is the a commandline option to upgrade to latest stabil version?
  Reply
#26
(04-15-2018, 02:45 PM)SkipperEarly Wrote: Had to update from 0.10 to latest stabil 0.17.1 and got same symptoms: only splash then
pi@op010:~ $ openplotter
Traceback (most recent call last):
 File "/home/pi/.config/openplotter/openplotter", line 3539, in <module>
   MainFrame().Show()
 File "/home/pi/.config/openplotter/openplotter", line 254, in __init__
   self.read_i2c()
 File "/home/pi/.config/openplotter/openplotter", line 1899, in read_i2c
   self.list_i2c.Append([str©, name, address, magn_list[c], iii[0], str(iii[1]), str(iii[2])])
UnboundLocalError: local variable 'magn_list' referenced before assignment

followed the advise earlier but to no joy.
Is the a commandline option to upgrade to latest stabil version?

http://forum.openmarine.net/showthread.p...01#pid2501
  Reply
#27
Sad
did as advised
sudo chmod +x /home/pi/.config/openplotter/update/update_OpenPlotter.sh
followed by
/home/pi/.config/openplotter/update/update_OpenPlotter.sh

but
$ openplotter
Traceback (most recent call last):
File "/home/pi/.config/openplotter/openplotter", line 3539, in <module>
MainFrame().Show()
File "/home/pi/.config/openplotter/openplotter", line 254, in __init__
self.read_i2c()
File "/home/pi/.config/openplotter/openplotter", line 1899, in read_i2c
self.list_i2c.Append([str©, name, address, magn_list[c], iii[0], str(iii[1]), str(iii[2])])
UnboundLocalError: local variable 'magn_list' referenced before assignment

I am stuck now, will try to start from 0.10 > 0.17.1 again as soon as I find time. (But maybe 1.0 will arrive before that)
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)