This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[RESOLVED] tty on GPIO with RPi2
#1
Hello

Apologize me for my poor english.

i use an tty-usb adaptator
cutecom are installed, and can receive datas sended by an other computer.
i try to made same, but with tty on GPIO (with an rs232-ttl adaptator) but minicom send me a error message : cant open.
how to for use this device ?
And, after, use this device for openplotter ?

i have gps and instruments on 1 DB9 plug  :-)

Thanks by advance
Bernard Mayer
  Reply
#2
I assume you are using the Raspberry Pi UARTS on GPIO 14 and GPIO 15?

If you are using a RPI3, you need to first disable the Bluetooth connection, as it uses the RPI UART.

You might be better off using a USB-DB9 converter.

There is a good description of RPI UARTS here: https://www.raspberrypi.org/documentatio...on/uart.md
  Reply
#3
(12-04-2017, 01:39 PM)abarrow Wrote: I assume you are using the Raspberry Pi UARTS on GPIO 14 and GPIO 15?

If you are using a RPI3, you need to first disable the Bluetooth connection, as it uses the RPI UART.

You might be better off using a USB-DB9 converter.

There is a good description of RPI UARTS here: https://www.raspberrypi.org/documentatio...on/uart.md
pins 8 and 10 (physical) , pins 15 and 16 (wPi), pins 14 and 15 (BCM)
i see that by $ gpio detectall

it's RPi 2


i like simple things, like my boat :-D

:-) thanks abarrow !

i try all yesterday long, and, after a good nigth, (and a good job day), i have the solution.
Raspbian start using this tty for his own console.
its mandatory to modiffy /boot/cmdline.txt (caution, this file are made in 1 line)
to suppress "console=serial0.115200" from this line
Shy
Thanks to https://raspberrypi.stackexchange.com/qu...ian-jessie
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)