• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Introducing CAN-USB Stick
#11
Openplotter converts n2k into signal k. OpenCPN does not understand signal k, so you have to converto to NMEA 0183. You can try using the signal k plugin "Convert Signal K to NMEA0183", visit http://localhost:3000/plugins/configure/. This plugin sends data to TCP localhost:10110
  Reply
#12
Thanks Sailoog

I upgraded to the latest 12 alpha this morning and tried to configure this signalk plugin.

On the plugins page i have two seemingly identical 'convert signalk to nmea0183' options

Both have an 'rmc' option for position data, but no 'rmb' which seems to be the only sentance that kplex is sending to opencpn?

I enabled 'rmc' but nothing happened that i can see?

Any further advice, would really like opencpn to be able to use n2k data, thats what i primarily bought the can adapter for!

Steve
  Reply
#13
Update!

Opencpn is set to 'exclude' rmb so the rmc should work.

I enable the translation but dont see anything in opencpn

Do i need to set up a new connection, if so what connection settings do i need?

Im back in the uk now so will be a while before i can test on Amita, is there any way of debugging away from the n2k network

Thanks in advance for any help!

Steve
  Reply
#14
Hi, I also just installed the CAN USB Stick on my network and do get some input on N2K and SignalK. What I didn't find in SignalK, though, was AIS data. I know it's on the bus, since I can see it on Raymarine MFD. Any ideas? I'm on Openplotter 12alpha on RasPi3
  Reply
#15
I did see ais data on signalk, are you sure your ais sends its data via n2k and not nmea0183 ?
  Reply
#16
I'm trying to get the SignalK to NMEA0183 plugin to work

away from the yacht so dont have much data but do have Magnetic Heading in signalk from an imu,so should be able to generate the nmea0183 heading sentance.

looking at the configuration readme for the plugin :

"Signal K Node server plugin to convert Signal K to NMEA 0183. See the code for a list of supported sentences.

To use the plugin you need to

activate the plugin and the relevant sentences under /plugins/configure (see image below)
add a configuration toStdout to the serialport you want the sentences to go to
...
}, {
"id": "nmea-out",
"pipeElements": [{
"type": "providers/serialport",
"options": {
"device": "/dev/nmea-digyacht",
"baudrate": 4800,
"toStdout": "nmea0183out"
}
}, { "

I have activated the plugin and selected the heading sentence, but where do i put the configuration code as above to send the data to opencpn ??

Steve
  Reply
#17
Update!

Ive experimented a little and seem to have made progress.

Opencpn has an input specified on 10109, i turned this off and added an input on 10110
My magnetic heading shows up in the nmea window!
It shows up even if the signalk to nmea0183 plugin is disabled ?

I then turned on the signalk emulator, for wind information.
Enabling the plugin for wind does result in wind nmea data reaching opencpn
I could not emulate position data as the signalk emulator does not provide this option.

So, is that a solution, merely connecting opencpn ro port 10110 instead of 10109 ??

I'm thinking that will get position/cog/sog info into opencpn once n2k is connected on Amita.

Next is ais ?

Steve
  Reply
#18
(07-15-2017, 08:14 AM)Sderbyshire Wrote: Update!

Ive experimented a little and seem to have made progress.

Opencpn has an input specified on 10109, i turned this off and added an input on 10110
My magnetic heading.....

Hi ! 

By changing to TCP localhost:10110, on OCPN, You are connecting direct to SK plugin instead of connecting to KPLEX. So this is a way if You don't have any NMEA0183 info just N2K. Tested and OK on my N2K network.

Another way should have been adding an input, TCP localhost:10110, to KPLEX and then don't change anything to OCPN, but this doesn't work ?? Maybe @Sailoog kan explain ? 

Regarding the N2K AIS there is a pretty new plugin available which should work.

Openplotter => SignalK => klick on ”Show Signal K Tools”

In the Browser, with OP connected to Internet, klick on ”App Store”

Choose instal for ”N2K AIS to NMEA0183”
After installation ”Reboot” the RPi

Once more go back to ”App Store” an klick on the name ”N2K AIS to NMEA0183” which will show ”Signal K Server Plugin Configuration”
and activate the ”N2K AIS to NMEA0183” plugin

I have checked the installation, OK, but couldn't check the function since I don't have N2K AIS info

This data will also be sent out on TCP localhost:10110

/Mats
  Reply
#19
Thanks everyone, will try and reply once I'm back on board.
  Reply
#20
Thanks Mats

Im not on Amita for a rew weeks so wont be able to try the n2k interface in the real world for a while

I will report back when i can

Steve
  Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)