• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No wind data in Signal K stream after upgrading to 0.17.0
#1
just upgraded to OPlotter 0.170 from 0.16.0 and everything seems to have gone well.

There's only one thing that doesn't seem to work. I have wind, depth and speed data in NMEA0183 format. This data is displayed correctly on the OCpn dashboard. Besides, I can check that they're in the NMEA viewfinder. However, wind data are not shown in Signal K. Others such as those of speed and depth yes. I can see them in Signal K.But only wind data are not shown even though the other are showed both in the NMEA0183 stream and signal k.

In 0.16.0 it works as expected.
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
  Reply
#2
Any error on terminal?
Type openplotter, restart signal k from signal k tab and wait for any error message.
What type of NMEA sentences do you send? are they supported by NMEA 0183 parser? https://github.com/SignalK/signalk-parser-nmea0183
  Reply
#3
Ahora mismo ya no te lo puedo mirar ya que no estoy en el barco y tardaré en volver a ir. Sencillamente, tras actualizar todos los paneles funcionaban menos el de viento. Y los datos estaban en el flujo NMEA0183.

Al mirar en el visor de Signal K no aparecían los de viento pese a que los otros de sonda y corredera temperatura etc si.

El caso es que con las anteriores siempre funcionaba. Curioso. Son los datos extraídos de Seatalk con el convertidor de YAPP. Recuerdo que era MWV.

Translated:
Right now I can't look at you anymore since I'm not on the boat and I won't be there for a while. Simply put, after updating all the panels, they worked less than the wind. And the data was in the NMEA0183 stream.


When looking at the Signal K viewer, they did not appear even though the other temperature sensors and temperature sliders etc. did.


The fact is that with the previous ones it always worked. Funny. It is the data extracted from Seatalk with the YAPP converter. I remember the MWV sentence.


Añado: Acabo de probarlo en casa con los datos de Diavolo a través de la red y se muestran correctamente. Así que por lo visto el problema es solo mio. No es general. Ya os lo dire si lo soluciono, por si a alguno mas le pasa.

Translated:Add: I just tested it at home with Diavolo data over the network and it is displayed correctly. So apparently the problem is just me. He's not a general. I'll tell you if I fix it, in case anyone else does.
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
  Reply
#4
Well Sailoog, I have already found the problem that caused me the failure of the wind indicator in signal K.

I don't know if you remember that years ago, in la taberna del puerto we commented on a certain error that we found in the YAPP converter.

In fact, it was you who found him. The code of the YAPP Seatalk-NMEA0183 converter emitted two different wind instructions. One was the IIVWR that worked well and the other was the IIMWV that was sent as knots but the data was actually served as kilometres/hour.

As OCpn read and understood both, filtering the second was enough to get the correct wind speed data on OCpn.

So far, the same thing has happened at Signal K. It filter the erroneous sentence and Signal K understood the "good"one, but since the last update it is no longer so.

Is there any simple way to make Signal K recognize IIVWR as a wind sentence again or will I have to settle for the previous version of Signal K in order to use the wind data?

I find the reprogramming of the Seatalk-NMEA0183 converter to be very unfeasible.

Translated to spanish:
Quote:Bueno Sailoog, ya he encontrado el problema que me causaba el fallo del indicador de viento en signal K.

No se si recuerdas que hace años, en la taberna del puerto comentamos cierto error que hallamos en el conversor de YAPP.

De hecho fuiste tu el que lo encontro. Y es que el código del convertidor Seatalk-NMEA0183 de YAPP emitia dos sentencias de viento diferentes. Una era la IIVWR que funcionaba bien y la otra era la IIMWV que se enviaba como nudos pero el dato era en realidad kilometros/hora.

Como OCpn leia y entendia las dos, bastaba con filtrar la segunda para tener los datos de velocidad del viento correctos en OCpn.

Hasta ahora, en Signal K sucedia lo mismo. Filtraba la sentencia erronea y Signal K entendia la "buena", pero desde la última actualización ya no es así.

¿Hay alguna manera sencilla de hacer que Signal K vuelva a reconocer IIVWR como sentencia de viento o me tendré que conformar con la version anterior de Signal K para poder usar los dato s de viento.

Lo de reprogramar el convertidor Seatalk-NMEA0183 lo veo mucho mas inviable.
It's not like the sea has such a bad temper.
The real bastard is the wind.
The sea... simply gets carried away.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)