• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pulseaudio client.conf
#1
Hello, 
    I'm trying to set up pulseaudio to stream to a bluetooth speaker.  There's a process somewhere that keeps overwriting my /home/pi/.config/pulse/client.conf file which disables autospawn and sets the pulse binary to /bin/true.  Where is this coming from so that I can disable it.  I plan to eventually install a stereo on the boat and direct wire using a DAC hat but for now all I have is bluetooth (external adapter) and the Pi's 3.5mm jack which is unusable due to the background noise.  



Here's what I'm trying to do.  I installed the NOOBS 0.10.0 version and have since upgraded to 0.17.0.  I have a set of custom scripts that I'm trying to get working that speak the boat speed and time at regular intervals (every 30 seconds for speed and every 15 minutes for time).  I have 2 custom services that I run as systemd User units.  One is a to-the-second scheduler script I wrote and the other is a daemon that uses inotify to watch a directory and then plays whatever audio file is dropped in there then deletes it.  When a file is dropped in the dir my playdaemon script detects it (inotifywait), records the current volume of all pulse sink-inputs, lowers all pulse sink-inputs by 15%, plays the voice file at the original volume, then brings all the volumes back up to their original values.  

I had this mostly working before on a ground up install using Raspbian Jessie but something else is clobbering my settings.  I've tried running pulse as a system instance but either I'm not configuring it right or again, something is borking it.  

Any suggestions?
  Reply
#2
(01-12-2018, 03:29 PM)cmgreenman Wrote: Hello, 
    I'm trying to set up pulseaudio to stream to a bluetooth speaker.  There's a process somewhere that keeps overwriting my /home/pi/.config/pulse/client.conf file which disables autospawn and sets the pulse binary to /bin/true.  Where is this coming from so that I can disable it.  I plan to eventually install a stereo on the boat and direct wire using a DAC hat but for now all I have is bluetooth (external adapter) and the Pi's 3.5mm jack which is unusable due to the background noise.  



Here's what I'm trying to do.  I installed the NOOBS 0.10.0 version and have since upgraded to 0.17.0.  I have a set of custom scripts that I'm trying to get working that speak the boat speed and time at regular intervals (every 30 seconds for speed and every 15 minutes for time).  I have 2 custom services that I run as systemd User units.  One is a to-the-second scheduler script I wrote and the other is a daemon that uses inotify to watch a directory and then plays whatever audio file is dropped in there then deletes it.  When a file is dropped in the dir my playdaemon script detects it (inotifywait), records the current volume of all pulse sink-inputs, lowers all pulse sink-inputs by 15%, plays the voice file at the original volume, then brings all the volumes back up to their original values.  

I had this mostly working before on a ground up install using Raspbian Jessie but something else is clobbering my settings.  I've tried running pulse as a system instance but either I'm not configuring it right or again, something is borking it.  

Any suggestions?

Not your actual prob, but
With something like this all Audionoises are gone with the pi internal: „Ground Loop Noise Isolator, HAVIT 3,5 mm Car Audio“
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)