This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Send nmea0183 to ethernet connected chart plotter
#1
I have a Garmin gpsmap 5212. It supports 3 network ports, an nmea0183 port and a nmea2000 port. I'd like to connect it to the pi3 OP v0.17.0 by ethernet to the network port. 

I tried to enable bridge to eth0 on the WiFi AP tab, clicked apply, and see br0 connection. I connected an ethernet cable from the pi to the chart plotter, but when I go through the Garmin comms setup, "no network device is found." 

I bumped into this site http://www.patmcqueen.com/home/garminmarine which details the use of the specific IP addresses 172.16.x.x. as the magic sauce in a different situation - they were trying to get data OUT of the chartplotter to an AP point to be accessed by idevices back in 2013. I want to get the data IN. Its a good read - short and concise and I think it can help solve this puzzle. 


I've searched through the forum and tried to specify the static ip address in /etc/network/interfaces, with and without removing the #generated by openplotter line. 
I've tried changing the WiFi address to 172.16.0.20 etc in ~/.config/openplotter/openplotter.conf , but after rebooting, ifconfig shows me as 10.10.10.1, and /etc/network/interfaces is overwritten by openplotter to 10.10.10.1. And after disabling 'bridge to eth0' wlan0 no longer is in the drop down box so, OP wont let me apply any changes to the WiFi settings. Reboots are my friend....   

I have zero depth in networking, and have run out of ideas. 

Has anyone had success setting up an ethernet bridge w OP, or have ideas about how to solve this puzzle? 

Many thanks.

Hank
  Reply
#2
Following up - The article I'm following said:
Plugging in a very basic configuration of a router and hub into the Garmin 5212 allowed Garmin BlueChart IOS to communicate with the 5212.  The only configuration of was to use 172.16.0.0/16.

OK. I found this post http://forum.openmarine.net/showthread.p...ght=Garmin in the forum on the same topic, and following e-sailing's advice I now have a br0 connection to 172.16.0.0.  On my laptop, i disabled the wifi, and connected ethernet cable between the pi and laptop, started opencpn and set up a connection to 172.16.0.0:10110 and Yes! - I get the nmea data. Moved the ethernet cable to the Garmin plotter and no devices found....

So, perhaps I need port 16 as mentioned in the article.  In Openplotter on the NMEA tab I set up a connection to 172.16.0.0 port 16 as TCP out and enabled it. On the laptop I edited the opencpn connection to 172.16.0.0:16 and activated it... but no nmea data.

If I go back to 172.16.0.0:10110 in opencon I see the nmea data, but nothing to 172.16.0.0:16.

I tried to disable the default opencpn TCP out connection to port 10110, but even though deselected, it restarts when I hit apply. I tried to edit kplex.conf and #comment the opencpn section, but it restarts.

So... does anyone know:
1) Does all Openplotter nmea output go to port 10110 regardless of setting a new TCP out connection to a different port? Anyway to override that for testing this ?
2) Is it possible that there is contention with the opencpn tcp out connection? If so, is there a way to disable it?

Thanks for any thoughts, ideas, expertise!
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)