This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] node-red 'MQTT in' disconnected
I had MQTT in and MQTT out nodes working in node-red - then last night they died - a  little red square and "disconnected" under the node. I've tried localhost:1883,, running node red on the pi and on my connected laptop, starting and stopping mqtt, and reboots.

I revived my old cloudmqtt broker/ and they are getting and displaying the mqtt data. 
Here are the /var/log/mosquitto/mosquitto.log  entries
1517338412: New connection from on port 1883.             <--- this is cloudmqtt  umifqkims is username
1517338412: New client connected from as                        @:vvXqbR:7USncFdC<@3q2qV@pkr_tMo6K\^3F8==MQl8WWKdWNLY6cigERMAp3G (c1, k60, umifqkims).   
1517338412: New connection from on port 1883.         <-------------I think these  three are my MQTT in nodes 
1517338412: New connection from on port 1883.                          trying to connect 
1517338417: New connection from on port 1883.
1517338417: New client connected from as 2_e5um2sBSf:2DUV[drtZ\THbvesmh1oOfd;Kg5MA[W3_lYAWS<ro`AX^gBBFCre (c1, k60, umifqkims).  

So - the data is there and getting out - just not getting into node-red. 

The 'websocket in' localhost:3000 node is connecting and receiving data and sending output to the dashboard. For a brief moment this morning the 'MQTT in' node connected, then it "Disconnected" again. 

Im in MQTT jail!   Sad

Ideas? How can I troubleshoot? 

on the mqtt node server is the tab security set to what you have on the server?
mare liberum
(01-31-2018, 05:49 AM)jim321 Wrote: on the mqtt node server is the tab security set to what you have on the server?

Thanks Jim. That did it. 

I had commented out the allow_annonymous false entry in /etc/mosquitto/conf.d/openplotter.conf and was able to connect. I was going to add a note to the forum about that when I saw your note. 

I removed the comment and restarted and after entering the user/pass on the mqtt node security tab everything is working again.

I appreciate your help Jim!


Forum Jump:

Users browsing this thread: 1 Guest(s)