• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
@mxtommy KIP instrument display webapp for Signalk
#1
I have mentioned this app in a couple threads, but I think it is exciting and nobody is talking about it much.

You can install it from the browser in Openplotter: go to localhost:3000 then App Store and it is the first listed as you scroll down to webapps.

[Image: cae1957675c09088d989d37614a8d178.jpg]

This has been IMO the biggest missing element in Openplotter for some time: really attractive open source instrument data display, for consumption on a screen connected to the pi or in a browser on any device on board or elsewhere in the world.



Sent from my Moto G (5) Plus using Tapatalk
  Reply
#2
I, too, have been looking for an OP substitute for an expensive ($500) B&G/Raymarine i70s/Garmin GMI20/Furuno F170 4" or 5" multifunction instrument display. In fact I have been looking for a 4"-5" touch display with bezel that fits this footprint. Anyone have any ideas for SW or HW that might fit the bill?
  Reply
#3
Very interesting these demo SignalK instruments.

But how to connect these to the real SK stream ?

Perhaps I overlook something. But I have not found a simple solution to
get the instruments working.

Regards,


Bram
  Reply
#4
Good spot!
Thanks for letting us know - I hadn't noticed. Will play around with some "proper" SK data tomorrow.
  Reply
#5
I fried another pi so I can't take it through the steps, but basically load the demo dashboard and then in settings change the demo url to localhost. I may have needed to fiddle with the path too.

Sent from my Moto G (5) Plus using Tapatalk
  Reply
#6
(02-05-2018, 10:46 AM)Saqqara Wrote: I fried another pi so I can't take it through the steps, but basically load the demo dashboard and then in settings change the demo url to localhost. I may have needed to fiddle with the path too.

Sent from my Moto G (5) Plus using Tapatalk

OK so I see in the demo json config it has "signalKUrl":"http://demo.signalk.org"
I tried replacing "http://demo.signalk.org" with "ws://localhost:3000/signalk/v1/api/" but KIP puts up API URL: Unknown Error
what should go in there ?

A fried pi sounds unpleasant  Sad
  Reply
#7
WOW, thanks Saqqara, I did not know it.

This should be enabled by default on next OP version!!!

Affinite, put just http://localhost:3000
  Reply
#8
I feel that my NodeRed dashboard might soon be redundant
  Reply
#9
   

(02-05-2018, 04:08 PM)Sailoog Wrote: WOW, thanks Saqqara, I did not know it.

This should be enabled by default on next OP version!!!

Affinite, put just http://localhost:3000

Hi Sailoog,

it works with this setting. But you have to setup the items for the instruments you like to have and also in which shape.

With Linux it can be done in a separate window in combination with navigation screen.
  Reply
#10
on my pi the address is
http://localhost:3000/@mxtommy/kip/#/page/0
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)