Full Version: Navionics AIS
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm trying to get the AIS function on the latest Navionics upgrade to work with data from either kplex, OpenPlotter or Signal K.

So far without luck.

I've created a UDP stream on port 2000 with the VDM messages and an RMC message.  I have confirmed via a simple UDP reader app that the messages are being received by the device but the Navionics app remains AIS-less.

Navionics steadfastly refuse to answer any questions and refer me to their "list of supported devices" which makes me believe that there is something more required than just the AIS messages ...

I've found users on other forums ( who claim to have it working but for some reason they are reluctant to provide details of the messages/data being sent to the Navionics app.

Maybe a dumb question, but did you activate the AIS overlay on the Navionics app?

Sent from my CLT-L04 using Tapatalk
I decided to give it a try myself, with my Quark-Elec AIS receiver. Same thing - the device is definitely sending out AIS data, but Navionics isn't receiving it.

On thing I tried was the "Connect Device" dialog in the menu. Even though I'm sure I'm connected to the AIS receiver, Navionics just sits in says "Waiting for Connection".

I'm going to have a word with the guys at Quark-Elec and see if they can shed any light on it. Hopefully that'll also help with OpenPlotter output.
It is working sometimes for me.
Create new UDP connection at openplotter kplex, port 2000, out.
Create new UDP connection at OpenCPN, port 2000, out. IP
From Navionics app connect to openplotter network.
In my case it is always "waiting for connection" but then I press the backwards arrow and magically it is green and connected.
I receive AIS targets and external GPS.
Good luck.
I got my answer on the Quark-Elec box - the Navionics app only supports UDP and the Quark only supports TCP.

So, in my case, I'll take the strings into OpenPlotter and output them on UDP port 2000.

According to the folks at Quark-Elec, Navionics claim that a future upgrade to the app will support TCP protocol.
(2019-07-23, 01:04 AM)uriguri Wrote: [ -> ]Create new UDP connection at openplotter kplex, port 2000, out.
Create new UDP connection at OpenCPN, port 2000, out. IP

Isn't that a duplication? Why do you also need an OpenCPN out port?
I just got mine to work by creating an outgoing UDP port 2000 stream in Openplotter (Kplex). I started by declaring the address of the tablet, which worked, and started working back to finally declaring the address of That still seemed to work. The connection dialog continued to spin as Uriguri described, but the "AIS: Receiving Data" was there after I backed up. For some reason, both my Navionics instances (one on the boat and one at home for testing) think I've got a Digital Yacht WLN10 connected.

The connection to the tablet was in and out at first, but is now fairly stable. Even after a couple of hours, some targets never display their call sign, only their MMSI. I can't say I'm that impressed with the functionality, but all I have now is targets that are in the marina. Hopefully Navionics actually does something with moving targets other than just showing them on the screen as an image of a boat. It's summer here and the boats don't move much - hopefully I'll see something moving before long.
Hello, just an little Tip: 

UDP broadcast uses the last IP Adress in your Network. 
So with the standard you should send port 2000 to (or 

These "0" and "255" IPs are normaly reserved, so there is no device with this IP. 
Eventually or could work, 
but why should anyone use adresses outside of his own (private) network?
In my case, when I'm testing at home, I have the network 10 on the wifi from the Openplotter system, and network in the house, and connected to the OP system via Ethernet. Stuff might change in the future. I don't want to have to track down every network definition.

If I become concerned that port 2000 gets routed outside my local net, I'll filter it or subnet it as you described.

Sent from my CLT-L04 using Tapatalk
Mine is working, sort of...

RPI 3, running OP 1.2, receiving AIS data from USB serial connection. Rpi is connected to Raymarine ES 75 plotter via plotter's Wifi.

There is a kplex entry to send all msgs to Ipad IP (also connected to plotter's wifi) via UDP port 2000.

Well, AIS target start to pop up a minute or two after Navionics is open on the plotter, but, I used to be able to receive depth as well... (even before AIS was available) now, there is nothing I can do to receive depth info. Any ideas?
Pages: 1 2