Full Version: AP Throughput and latency
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've tried to make it work but after several weeks i might as well seek help now.

I have a usb 4g modem connected to my Rpi4, as well as a USB NIC.

I use the currently latest OP (Settings 2.3.0).

On the OP computer, i get 7+ Mbit speeds and normal surfing, no issues there. Both 4g and Wifi internet connection works.

Using the onboard wifi as AP, in 2.4Ghz, tried different channels and also what device should be shared.

For all connected clients (Windows laptops, Android phones/pads) the latency is 1000+ms and very poor performance in general.
While doing speedtests on clients the cpu load on the Rpi4 only increases slightly, so not a bottleneck there.
It's impossible to watch videos and connecting going up/down/fast/slow/on/off....

I also tried using the USB NIC as the AP, for testing purposes, but that wont work wither. 
It can connect to the AP but no internet connection is shared.

So I really can't get around to get proper internet shared through the AP on board. Ideas?
Do you have anything using USB3? If so, try disconnecting it and testing again. You also might try 5G Wifi. Apparently there are issues with 2.4 G wifi and the USB 3 controller.
I use 2.4 and the issue occurs regardless of the external USB Wifi connected or not.
Tried to switch to 5Ghz wifi but no real change - only to the worse.

The USB Wifi is connected in the USB3 onboard, the USB 4g modem is connected through a hub to the USB2 on board.
Using WiFi only as shared connection works much better, seems like involving a usb modem causes some kind of problem.