OpenMarine

Full Version: Raspberry 4 + moitessier hat / signalk -> opencpn: freeze
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
After tryng to use signalk directly in opencpn the gps data seems to be unstable, with random data and freeze opencpn.

Using signalk->nmea convertor and nmea as input in opencpn there wasn't any problem.

Now because of the opencpn freeze i can't go back to the nmea input configuration.


Any suggestions?
is the signal k connection the only one?
to start opencpn from scratch remove the folder /home/pi/.opencpn
please if the issue persists please report to opencpn developers
(2020-09-14, 06:52 PM)Sailoog Wrote: [ -> ]is the signal k connection the only one?
to start opencpn from scratch remove the folder /home/pi/.opencpn
please if the issue persists please report to opencpn developers
I got the same difficulties : gps unstability, and OpenCPN freezing (25% CPU occupancy, i.e. one core occupied 100% (= looping ?) and impossibility to close OpenCPN but using task manager to terminate it. I also had the idea to uninstall / re-install but with few success.
I applied the Sailoog's advice to remove the directory .opencpn, we will see how it goes. More report later...
(2020-09-22, 04:55 PM)Didier B Wrote: [ -> ]
(2020-09-14, 06:52 PM)Sailoog Wrote: [ -> ]is the signal k connection the only one?
to start opencpn from scratch remove the folder /home/pi/.opencpn
please if the issue persists please report to opencpn developers
I got the same difficulties : gps unstability, and OpenCPN freezing (25% CPU occupancy, i.e. one core occupied 100% (= looping ?) and impossibility to close OpenCPN but using task manager to terminate it. I also had the idea to uninstall / re-install but with few success.
I applied the Sailoog's advice to remove the directory .opencpn, we will see how it goes. More report later...

Hi, same configuration and same problems. OpenCPN freeze!  Huh
Hi all
please see  my post
It seems Open CPN is confused about having a FIX when GPS is long to deliver reliable position information ...
https://forum.openmarine.net/showthread.php?tid=2954

marking as solved, reopen if necessary
I updated Signal K Installer and Serial today.  When I activate the signal K network connection, I lose GPS.  When I put it back to the older way, GPS reconnects.  I verified that signal k version is 1.34 and all other updates have been installed.

I did not delete the .opencpn directory yet because I'm not sure if it is still needed and if so, how exactly so I need to do it so I don't lose all my opencpn configuration.
I updated signalk server and installer too, but I have the same issue with no fix on gps. 

The sistem is unusless still the first time the issue arrived (after updating rspi and moitessier drive)
OK, reopening the thread, do not panic. It did not seem to me a signal k problem, so let's reopen the issue in OpenCPN support:

https://www.cruisersforum.com/forums/sho...ost3239078

I can not reproduce the issue, so please all of you suffering this try to share your scenario there.
(2020-09-29, 10:25 AM)Sailoog Wrote: [ -> ]OK, reopening the thread, do not panic. It did not seem to me a signal k problem, so let's reopen the issue in OpenCPN support:

https://www.cruisersforum.com/forums/sho...ost3239078

I can not reproduce the issue, so please all of you suffering this try to share your scenario there.

Hi Sailoog,
i don't think it's a opencpn issue, yesterday semms everything works after sometimes that rspi was working. After closed and reopened opencpn the issue come again.

My configuration is:
Rspi 4
Moitessier hat 1
Everything updated

Untill when i update rpi firmware and moitessier hat drive (changing to signalk configuration for opencpn) there wasn't any problem.

Let me know how can i give you more information to reproduce the issue.
Pages: 1 2 3