Full Version: no sound on opencpn
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I try to use opencpn as an anchor alarm with the watch dog plugin.
The plugin works, I can sea the alarm box.

But no sound !

However I have sound on Openplotter (VLC, internet browser...)
Openplotter is up to date, opencpn 5.2.4

on the opencpn option menu / user interface / sound device, I only have : unknow device: 0

if somebody have an idea to fix that I'm interested !!

many thanks by advance

(2021-06-25, 05:42 PM)Hydranico Wrote: [ -> ]Rpi 4
hmm... opencpn uses portaudio. I havent tried sound on the pi for a while. Can you confirm that sound output works from other programs like aplay? What does alsamixer show?

alsamixer shows :

/proc/asound/cards/cards :
0 [b1                    ]: bcm2835_hdmi - bcm2835 HDMI 1
                               bcm2835 HDMI 1
1 [Headphones   ]: bcm2835_headphonbmc2835 Headphones - bcm2835 Headphones
                              bcm2835 Headphones

I have selected the "headphone" soundcard but still no sound on opencpn while it's working on other applications...

But I wonder if the problem doesn't come from the watchdog plugin because when I select a .wav file as an alarm it isn't registered : if I click on ok on the alarm config window and if I edit again the alarm, no sound is selected...

Thanks for your reply !


the problem was the name of my alarm sound file...
it was rather long and complicated. It have changed it for "Alarm.wav" and it works perfectly.

thanks !!!
so you are saying having a long complex filename the watchdog cannot play it?

I am the author so what exactly was the filename? I can fix this.

I'm sorry but I don't remember the file âme but it was something like a sentence with spaces and maybe spécial letters.

But immediately fixed with a basic file name.