Full Version: RPi 4 Serial UART for GPS input
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi There,

I have a pi4 that I am trying to get a ublox 7m GPS module working on via the UART GPIO15 pins.

I am stumped regarding the primary and secondary UART serial connections. Apparently on the pi4 they are different (with a miniuart) to the earlier ones

There are a few overlay options one can specify in the config.txt file I have tried a few already, resulting in ttyAMA0, ttyAMA1, ttyS0,  but I still cannot get any of this data into signal k after aliasing the device and setting a connection in the serial dialog.

in my config.txt I have the following

these values come from the
documentation. But I still cant work it out. Has anyone else had to deal with this?

The easy option is aparently to go and get a USB GPS dongle. But I had this ublox NEO 7m by duinotech. It has an onboard antenna but also an sma to run an external antenna. I have previously read the nmea gps messages in sudo cat /dev/(serial port). but not through to signal k.

The module and guts of connecting this device I found in this video but i did not run the python scripts as I wish to use it with OP.

An help would be appreciated.

OK Update, as follows

I edited my config.txt file to include



sudo cat /dev/ttyAMA0

Got illegible GPS data.

Edited the serial device connection to signal K and set the baud to 9600.

Still no throughput to signal K.

hard Set the serial Baud rate to 9600 in terminal using 

stty -F /dev/serial0 raw 9600 cs8 clocal -cstopb



Problem solved. working like a charm. (5 total signal k throughput deltas/second and 15 signal k paths)

Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin Big Grin