Full Version: Faulty board or misconfiguration?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
It seems my MacArthur hat is not powering up. I tried several ways to power it, and finally dismantled and removed all wires I had (i had a need to tidy up everything anyway), and started from scratch folowing the docs for v1.2.

When I turn on my switch, the 12V led flashes for a fraction of a second and then it shuts down.

I tried the simplest wiring I could think of:

Battery negative (B-) to Black connector GND
Battery possitive (B+) to a fuse to a switch to the Black connector 12V

I tried the power module in the older (beta) MacArthur, and I had no issues at all, both 12V and 5V leds are on. I also tried the old power module in the new 1.2 HAT and it doesn't work.

So my guess is I have something wrong in my wiring.

According to the docs, since I have N2k network too, i should connect the V+ from the netowkr to the Seatalk1 V+ input (i don't undertand that), but in any case I tried to.

Just to clarify, I tested there's ~12.7V on the black connector of the HAT.

Any ideas? I'll be back to the boat tomorrow afternoon, and hope I can fix it, because on my N2K network I only have 2 Axiom+ displays, so they are kinda useless without OpenPlotter.
The 12V via switch should go to the 12V SW pin on the Seatalk1 plug. The black connector is connected to 12V (battery positive) and ground (battery negative).

The MacArthur HAT looks at 12V SW to turn on the power module.

Please share some pictures (or diagrams) if that's what you already have and/or not working.
Do you mean the black connector should be DIRECTLY connected to the battery (with a fuse of course), and that the switch should be connected to the 12V SW pin on the Seatalk1 plug?

And that way I can turn on/off the raspberry with the physical switch?

If that's true, I totally misundertood the connection diagram, since there's a switch symbol after the fuse on the V+ of the black connector :S
Yes, the black connector has to ALWAYS be connected to the battery (12V and GND) and the 12V SW connector has to ALWAYS be connected to the switch and the battery to turn the system on/off.

(2024-03-05, 12:19 PM)Sailoog Wrote: [ -> ]Yes, the black connector has to ALWAYS be connected to the battery (12V and GND) and the 12V SW connector has to ALWAYS be connected to the switch and the battery to turn the system on/off.

Gratis! It seems I couldnt understand the most basic diagram  Big Grin

Now it works fine, thanks!

Except for the N2K network, which show the 2 fixed leds. According to docs it means the network is not recognized. 

I think is another wiring issue. Since the n2k network is powered separatedly (from the same battery bank), do I need to connect V+ to 12V SW and/or V- to ground?
Be careful, do not use different power sources for the Raspberry and the NMEA 2000 network. If you are powering both from the same battery bank then you have only one source.

Forget the previous diagram, if you are connecting the NMEA 2000 bus, this is your diagram. You can also forget about the fuses if that is what confuses you:

So is this wiring correct? I also connected the ground wire, since I assumed it does nothing (being everything connected to the same battery), but maybe that's wrong.

And if the wiring is correct, what might be the issue? I didn't install the N2K network myself, instead I hired a company to install a couple of Axiom+ 9, which is the only thing connected to the N2K network, and ask them to leave a T connector right before the terminator resistance near the Raspberry. 

Since the T connector came with the (annoying) SeatalkNG format, they provided me a converter to the standard 5 pin connector described in the docs, and that's what you can see plugged in in the picture.


BTW, I already tried switching blue and white wires just in case, but the leds always stay fixed.

I also checked if there was any voltage between red and black wires coming from the 5 pin connector (before connecting them to the raspberry, of course), expecting to have the ~12.5V that the battery provides, but the multimeter shows ~0.01V. Does that means something's wrong with the N2K network?
- From your picture I have the impression that you have 2 wires  in "12V SW". If you followed the diagram for NMEA 2000 you should have only V+ there.

- Not having ~12V in V+ and V- is strange, have you tried measuring V+ and the shield wire?

- Is the CAN bus connected to the battery?

- Are both Axiom+ 9 turned on and communicating each other?

- The terminating resistors are there in your CAN bus? Follow this to verify:
  • With power off unplug connector from any device on the network and measure resistance between CAN Hi and CAN Low.
  • Resistance should be 60 ohms if both termination resistors are present.
  • If measurement is 120 ohms only one terminating resistor is present, two resistors are required (see note below).
  • If 40 ohms is measured a third terminating resistor is installed and should be removed.
  • If less than 40 ohms is measured there could be a short in the harness or a damaged CAN Port of one of the devices connected to the network.
  • Some CAN devices may have an internal termination resistor that is switched by software once the unit is powered up, consult manufactures literature to determine if this is the case.
I will check the resistor stuff this afternoon, thanks!

Also, I contacted the guy who installed the nmea network, and confirmed me they didn't connect it to 12V, as it was supposed to! (yeah, i knnow ...)

In my diagram, the small red wire on the 12V SW is the positive of the NMEA network. The blue one is the wire tha comes from the switch.

I guess to power the network properly, I should connect both V+ and V- to the HAT's black connector?
Alternatively, they gonna give me a SeatalkNG to V+/V- Wire to power up the network. I will take it since is free (after all it was they're fault), but it would be better if I can power the N2K network directly from the HAT.

This is the wire they give me to power up N2K network in case i cannot do it from the HAT:

Bufffffff Your system is a complete example of everything that should not be done Big Grin Big Grin 

In the NMEA 2000 diagram you will see that the CAN bus must be connected to the battery.

12V SW connector has to be connected only to V+ (positive of the CAN bus).

"I guess to power the network properly, I should connect both V+ and V- to the HAT's black connector? " NEVER!, your CAN bus should be connected to 12V by its own drop line and specially your network because you have 2 high consumption devices.

"it would be better if I can power the N2K network directly from the HAT. " Never! again Smile

You should apply this logic to design any NMEA 2000 network:

- The CAN bus should be powered directly from the battery.
- Any MFD or plotter should never be powered from the CAN bus, it should have its own power line from the battery. This include the Raspberry/openplotter.
- Only small displays or low consumption devices should be powered from the CAN bus.
- The 2 terminating resistors should be always present in the CAN bus. You can replace one of them (or two) by the internal termination resistor of one device if present but only if this device is at the end or at the start of the line. The MacArthur HAT has one termination resistor to do this.

[Image: attachment.php?aid=2709]
Pages: 1 2 3 4