OpenCPN pypilot plugin disconnected - Printable Version

+- OpenMarine (
+-- Forum: Pypilot (
+--- Forum: General discussion (
+--- Thread: OpenCPN pypilot plugin disconnected (/showthread.php?tid=3520)

Pages: 1 2 3

RE: OpenCPN pypilot plugin disconnected - Screenshot - 2021-07-12

In my first posts, I was on a system that had previously pypilot from openplotter. (that would explain why ~/.pypilot already existed). 

Now for testing purpose I'm on a "clean" system, just cloned and python3 install... 

Creating the ~/.pypilot folder worked, pypilot can now run. 
The connection to OpenCPN plugin works perfectly. 
But in the calibration GUI, the data only refreshes at 1 delta per second (either in accelerometers or compass). Sometimes, multiple red dots will be created at the refresh if the IMU is moved enough in 1s.
Maybe not related, but when I try to calibrate, the points are way out of the globe, which isn't the case with the 2.1.1 version...  
Leveling the boat works without issue (in a few seconds)

pypilot_client -c imu.rate   says 20/second 
pypilot_client -c imu.gyro  produces a lot of output per second (possibly 20) 

The compass value in pypilot & signalk is updated very rapidly, probably 20 times per second

after running pypilot_web, the web client (localhost:8000) works also well, with heading/pitch/roll updating rapidly.

RE: OpenCPN pypilot plugin disconnected - seandepagnier - 2021-07-13

Calibration is not available immediately, it takes some time to load, could this be a potential issue?

It seems like it is getting the data at 20 updates per second.

Now, it may have something to do with open gl drivers? I typically run the pypilot_calibration script on a remote host which is not a pi.

Can you go to the pypilot website (localhost:8000) and in calibration, click on the calibration plot link. See if the web version of calibration works any better. You should also be able to perform calibration from the opencpn plugin as well. Also, check the console of pypilot_calibration for errors. If possible, try these from a different machine too.

Thanks for taking the time to do this, you have uncovered a few small glitches which are now corrected in git. It would be good to find an explanation for the last problem with calibration. I will try to reproduce it as well from a fresh openplotter image.

As for points way out of the globe, likely it just is not calibrated yet. It is hard to say. It can vary widely with changes in position from magnetic objects as well. I will try to reproduce your result from the image.

RE: OpenCPN pypilot plugin disconnected - donovanes - 2022-06-28

(2021-06-24, 03:05 AM)seandepagnier Wrote: I believe what you have is the old version of pypilot and the new version of the pypilot opencpn plugin.   This is confusing (even for me) because the openplotter-pypilot plugin version 2.1.1 which is what is installed by openplotter will give you pypilot 0.15.    So you can either update pypilot directly from git, or it would be great if you could try out my improvements to openplotter-pypilot which are currently being evaluated but hopefully this version will be in openplotter soon.

Just use "sudo python3 install" and then try running openplotter-pypilot and update pypilot.    This gives a bit more control.   If you run into trouble let me know, and if you cannot update pypilot from the gui there just try pulling pypilot directly from git

again "sudo python3 install"

This should get everything updated to the new version of pypilot which automatically communicates with signalk (once you grant it read/write permission)

note:  port 20220 is not signalk, it is nmea0183

After struggling with the same connection issues discussed in this thread, I followed the instructions above and installed openplotter-pypilot from git and was able to successfully upgrade and connect the opencpn plugin with pypilot. I'm running pypilot 0.34 and openplotter pypilot version 2.2.0.  I have added an OpenCPN TCP in/out connection on localhost 20220 and set localhost in the pypilot plugin config

It works fine except there is one pesky issue which I was hoping someone could shed light on. The AP plugin shows disconnected every time I restart OpenCPN. I have to click on config (same host) and then ok and the connection works.  I've tried using as the host and it also works but I get the same issue. 

Any thoughts? Thanks!

RE: OpenCPN pypilot plugin disconnected - seandepagnier - 2022-06-29

Which version does it show for the opencpn pypilot plugin?

RE: OpenCPN pypilot plugin disconnected - donovanes - 2022-06-29

(2022-06-29, 08:11 PM)seandepagnier Wrote: Which version does it show for the opencpn pypilot plugin?

When I look in OpenCPN -> Options -> Plugins , I see pypilot plug in version

RE: OpenCPN pypilot plugin disconnected - seandepagnier - 2022-06-30

I think it must be recent changes that autodetect the pypilot ip address in version .35

you said you are on .34? Can you try the latest?