This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
segmentation fault
Hello Everyone,

I have an issue using OpenCPN through OpenPlotter. I have tried both methods described here: I have updated both openplotter and opencpn. OpenPlotter seems to work find but I cannot start OpenCPN! I tried on 2 different rapsberry (3B and 3B+, SD 16GB) But I have the same issue. 
When I try to double click on the icon nothing happens. When I type opencpn in the command line I get the message : SEGMENTATION FAULT
I tied to run it through the software ddd and here is what I get:

(gdb) run opencpn
Starting program: /usr/bin/opencpn opencpn
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/".

Program received signal SIGSEGV, Segmentation fault.
0x004032c4 in cm93chart::CreateHeaderDataFromCM93Cell() ()

I also tried to uninstall then reinstall OpenCPN without any luck...

Hope you can shed some light on this.

Thanks in advance,

Messages In This Thread
segmentation fault - by racoon44 - 2018-10-17, 01:15 PM
RE: segmentation fault - by seandepagnier - 2018-10-18, 06:09 PM
RE: segmentation fault - by racoon44 - 2018-10-22, 12:53 PM

Forum Jump:

Users browsing this thread: 1 Guest(s)