This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MPU-9250 not detected
#1
Photo 
Hope everyone is safe.  Trying to get some fresh eyes on my struggles to get my MPU-9250 working on my RPI4 with V2 of OP (fully updated).

Here's my MPU-9250:

   

I actually bought 2 of these (since Sean warned that a small percentage will be defective out of box) and results below are same with both.

From my reading, I understand that everything should be auto-detected in pypilot?  I believe the IMU is wired up correctly and it is detected at 0x68.

   

However, it does not show in "Sensors" in the I2C interface:

   

Pypilot interface shows "Detected IMU:  Auto Discover":

   

Output from "pypilot_boatimu" shows "No IMU detected":

   


I found this post where a forum member had a similar problem and maybe ran some code from a tutorial.  Do I have to do something to get my IMU set up?

Any pointers appreciated?
Reply


Messages In This Thread
MPU-9250 not detected - by w7thmark - 2020-04-21, 01:37 PM
RE: MPU-9250 not detected - by holgerw - 2020-04-21, 02:24 PM
RE: MPU-9250 not detected - by kinefou - 2020-04-21, 03:16 PM
RE: MPU-9250 not detected - by holgerw - 2020-04-21, 06:20 PM
RE: MPU-9250 not detected - by Sailoog - 2020-04-21, 06:54 PM
RE: MPU-9250 not detected - by w7thmark - 2020-04-21, 08:01 PM
RE: MPU-9250 not detected - by kinefou - 2020-04-21, 08:48 PM
RE: MPU-9250 not detected - by w7thmark - 2020-04-22, 12:15 AM
RE: MPU-9250 not detected - by seandepagnier - 2020-04-22, 01:38 AM
RE: MPU-9250 not detected - by w7thmark - 2020-04-22, 02:09 AM
RE: MPU-9250 not detected - by seandepagnier - 2020-04-23, 04:01 AM
RE: MPU-9250 not detected - by w7thmark - 2020-06-27, 09:20 PM
RE: MPU-9250 not detected - by rilova1975 - 2020-07-01, 04:52 PM
RE: MPU-9250 not detected - by kinefou - 2020-07-01, 07:49 PM
RE: MPU-9250 not detected - by seandepagnier - 2020-07-02, 05:51 PM

Forum Jump:


Users browsing this thread: 1 Guest(s)