This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BME280 > SignalK no data/gauges
#24
(2021-08-30, 01:03 AM)Jay_cd33 Wrote: Big Grin Big Grin Big Grin 
So I figured out the problem with not getting BME280 sensor data into SignalK described in my previous posts.

It turns out Adafruit has updated their BME280 python library used in the openplotter i2c app to read sensor data. So new installs download the updated library which breaks the openplotte i2c read app.  The openplotterI2cRead app runs as a service, reads the sensor data and sends it to signalk.  The problem is that the library import in openplotterI2cRead.py is not compatible with the new library.   So the openplotter i2c app sets up the bme280 sensor correctly and configures signalk with a good connection but no data is sent to that connection by the openplotterI2cRead app.

So Sailoog needs to correct the BME280 library import call in a future release.   For those that are willing to hack the changes necessary to make it work here is what I did...

In the directory;
/usr/lib/python3/dist-packages/openplotterI2c
The file openplotterI2cRead.py needs to be edited. (sudo needed to edit file),

Change line 44 (in the BME280 section)
from:        
        import adafruit_bme280

to:
        from adafruit_bme280 import basic as adafruit_bme280

(be aware the from is preceeded by 2 tabs not spaces).

After saving these changes, either restart the openplotter-i2c-read.service or reboot.

That fixed the problem for me.   I hope this helps others.  
I'm not a coder so Sailoog will probably have a proper fix in a future release.

Hi Jay_cd33,
Thank you for finding a solution to this issue. I hae spent three days on this! Now working fine :-)
Reply


Messages In This Thread
BME280 > SignalK no data/gauges - by faurmic - 2021-07-15, 01:55 AM
RE: BME280 > SignalK no data/gauges - by aywwa - 2021-07-15, 03:11 AM
RE: BME280 > SignalK no data/gauges - by faurmic - 2021-07-15, 04:30 AM
RE: BME280 > SignalK no data/gauges - by Lazzz - 2021-07-15, 03:41 AM
RE: BME280 > SignalK no data/gauges - by faurmic - 2021-07-16, 10:02 PM
RE: BME280 > SignalK no data/gauges - by faurmic - 2021-07-17, 05:32 PM
RE: BME280 > SignalK no data/gauges - by Jay_cd33 - 2021-08-27, 11:13 PM
RE: BME280 > SignalK no data/gauges - by Jay_cd33 - 2021-08-28, 02:49 AM
RE: BME280 > SignalK no data/gauges - by Lazzz - 2021-08-28, 03:34 AM
RE: BME280 > SignalK no data/gauges - by Jay_cd33 - 2021-08-28, 03:54 AM
RE: BME280 > SignalK no data/gauges - by Jay_cd33 - 2021-08-30, 01:03 AM
RE: BME280 > SignalK no data/gauges - by faurmic - 2021-09-06, 04:48 AM
RE: BME280 > SignalK no data/gauges - by angryemu - 2021-09-06, 02:51 PM
RE: BME280 > SignalK no data/gauges - by thequasarman - 2021-11-04, 02:08 PM
RE: BME280 > SignalK no data/gauges - by sebba - 2021-09-08, 02:32 PM
RE: BME280 > SignalK no data/gauges - by Matilda - 2021-09-18, 07:33 AM
RE: BME280 > SignalK no data/gauges - by Jay_cd33 - 2021-09-18, 09:17 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)