This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem installing V3 with moitessier HAT
I have the same configuration as the OP, spazio, but with 32bit OS (armv7l). I got the same error message. I subsequently installed stm32flash from the package manager and I still get the same error message. If I am understanding correctly that the install script is trying to execute a file and not a command from a dependency, there was really no reason for me to believe installing the flash utility would would help(and it is also a totally different version), but I couldn't think of anything else to try. But the problem is definitely not with the OS version. stm32flash should run under 64bit OS and it doesn't work under 32bit OS either. I think the "File ./stm32flash_5.15.32-v8+" is missing from the package. ...but I also barely know what I am talking about so maybe it is some other problem with the install script.

As an added bonus: now whenever I try to install something from openplotter-settings it gets stuck in a loop trying to install moitessier for a long time before it gives up.

Does anyone happen to know what the last working version of OpenPlotter for moitessier HAT2 was and where I can download that image? I found lots of broken links when I looked.

my system:
breezer@krystyna:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"
breezer@krystyna:~ $ uname -a
Linux krystyna 5.15.61-v7l+ #1579 SMP Fri Aug 26 11:13:03 BST 2022 armv7l GNU/Linux

Messages In This Thread
RE: Problem installing V3 with moitessier HAT - by flasher702 - 2022-09-17, 10:53 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)