This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LCD JLX12864 flashing
I for one suspect the initialisation sequence, looking at and there are some differences worth to be tested...
my driver may be different because you can plug and unplug the display at any time and it still works, so it resets all the registers every frame, but this may cause a refresh somehow.
I am not sure what is going on exactly but I think I fixed it:
Did you try adding a small delay between each boost command ?

Because in u8g2 I see this:
/* power on sequence from paxinstruments */
U8X8_C(0x028|4), /* all power control circuits on */
U8X8_C(0x028|6), /* all power control circuits on */
U8X8_C(0x028|7), /* all power control circuits on */

Just wondering...
Is this change compatible with both old and new displays ?

I just tested and it seems it works with my older JLX displays
Thanks Sean! Yes it works on both old and new version display!
I wonder why it works.
Yes it''s work on openplotter/Raspi3b after updating via

git clone
cd openplotter-pypilot
sudo python3 install
edit the hat.conf "default" to jlx12864


I also have a Tinypilot on a zero w (Build with the manual
If I want to do the update like in the workbook

mkdir pypilot-update
cd pypilot-update/
git clone git://
git clone --depth 1 git://
cp -rv pypilot_data/* pypilot
cd pypilot

the git command is not executed "fatal: unable to connect to"
pink works for example. I don't know what mistake I'm making.
github removed support for unauthenticated git recently :

You can clone over https as you did for openplotter: instead of git:// use and same thing for pypilot_data.
I had already tried that, but unfortunately no https connections via git seem to be established with Tinypilot images. Fatal error: Cannot find remote helper for 'https'

Forum Jump:

Users browsing this thread: 1 Guest(s)