This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update problem on RPi 3+
#21
Hallo zusammen, 
Ich habe heute auch versucht, ein neues OP 1.0.0 auf 1.2.0 zu aktualisieren. 
Vor dem Update habe ich 

Code:
sudo apt-mark hold hostapd

ausgeführt wird. 

Leider ist ein Bleich aufgetreten. 
wegen der Länge habe ich die Fehler in eine Textdatei geschrieben. Siehe Anhang. 
Vielleicht kannst du damit etwas anfangen. 
Grüße Jürgen


Attached Files
.txt   error.txt (Size: 18.07 KB / Downloads: 12)
Angel  Entschuldigung für mein Englisch. Es ist "deepl.com english"
PN bitte auf german.  Big Grin
Reply
#22
i had the same thing happen to me try this

sudo apt-mark unhold hostapd ......not needed if you didn't put in on hold

sudo systemctl enable hostapd.service

sudo nano /home/pi/.openplotter/openplotter.conf

change version = 1.2.0 to 1.0.0, mine was blank after update fail.

ctrl x y enter
reboot
try update again
mare liberum
Reply
#23
Hello, Jim,
Thanks for the tip.
I was able to update my system now.
But first I had to 

Code:
sudo apt-mark hold hostapd

and then insert your line

Code:
sudo systemctl enable hostapd.service


I didn't have to change the version number. Since the update failed it is still 1.0.0.

Now everything seems to be fine.

Thanks again.
Greetings Jürgen
Angel  Entschuldigung für mein Englisch. Es ist "deepl.com english"
PN bitte auf german.  Big Grin
Reply
#24
(2019-04-19, 10:30 AM)jim321 Wrote: i had the same thing happen to me try this

sudo apt-mark unhold hostapd

sudo systemctl enable hostapd.service

sudo nano /home/pi/.openplotter/openplotter.conf

change version = 1.2.0 to 1.0.0, mine was blank after update fail.

ctrl x y enter
reboot
try update again

Jim
I too had trouble upgrading from 1.0.2 but your steps worked for me so thanks
Steve
Reply
#25
Thanks Jim321 and Luckbert,

I had the same problem and your solution works perfectly also for me:


sudo apt-mark hold hostapd

sudo systemctl enable hostapd.service


Reboot and try update again.


Smile
Reply
#26
i dont think you need to mark hold on hostapd
just enable the hostapd.service
mare liberum
Reply
#27
I know this is an old thread but I too am having a problem upgrading a version 1.0.0 to 1.2. I want this as well as a version 2, which is fine.
Version 1 is much simpler for 0183 NMEA only streams.

The problem is a PYTHON compatibility problem, as when using the upgrade tool for 1.0 to 1.2, I get  the following below.
Is there any solution?
Richard

UPDATING PYTHON PACKAGES...

Searching for pip
Best match: pip 9.0.1
Adding pip 9.0.1 to easy-install.pth file
Installing pip script to /usr/local/bin
Installing pip2.7 script to /usr/local/bin
Installing pip2 script to /usr/local/bin

Using /usr/lib/python2.7/dist-packages
Processing dependencies for pip
Finished processing dependencies for pip
Collecting paho-mqtt
 Using cached https://files.pythonhosted.org/packages/...5.1.tar.gz
Collecting pyudev
 Using cached https://files.pythonhosted.org/packages/...2.0.tar.gz
Collecting pyrtlsdr
 Using cached https://files.pythonhosted.org/packages/...ne-any.whl
Collecting pynmea2
 Using cached https://files.pythonhosted.org/packages/...5.0.tar.gz
Collecting twython
 Using cached https://files.pythonhosted.org/packages/...8.2.tar.gz
   Complete output from command python setup.py egg_info:
   Traceback (most recent call last):
     File "<string>", line 1, in <module>
     File "/tmp/pip-build-T_Ycjz/twython/setup.py", line 33, in <module>
       long_description=open('README.md', encoding='utf-8').read() + '\n\n' +open('HISTORY.md', encoding='utf-8').read(),
   TypeError: 'encoding' is an invalid keyword argument for this function
   
   ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-T_Ycjz/twython/ (IN RED)
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)