This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MQTT String payloads to Integers for use in KIP gauge

Is there a way to alter the incoming MQTT datatype (defaults to string) to integer? This is needed because I'm building an interface for the engine in my boat. I would like to publish RPM, coolant temperature and oil pressure to MQTT en display them using the fancy gauges in KIP. These do not accept the string data that was received and linked to SK.

Kind regards,

Have you tried to do something in Node-Red?
(2019-05-12, 07:51 PM)abarrow Wrote: Have you tried to do something in Node-Red?

Yes I did ... But i found a fix to my problem after fiddling around a bit. I selected the propulsion.* and typed in the revolutions in the wildcard placeholder. That worked like a charm but the data was interpreted as String.

Next I selected propulsion in the group drop-down box in the "Select Signal K key" window and instead of typing propulsion for the wildcard I selected "propulsion.*.revolutions" in the Keys drop-down box. I entered engine for the wildcard. This yields propulsion.engine.revolutions as Signal K topic and OPnotifications.MQTT.myTopic as source. Data is received as string and interpreted as a numeric value. 

Looks like my problem is solved doesn't it? No it isn't. Now I can't find my "propulsion.engine.revolutions" in KIP when I configure my page. Actually the only keys available are the navigation keys. What am I missing out on here?

Kind regards,


Forum Jump:

Users browsing this thread: 1 Guest(s)