This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server Hardware for openplotter?
(2020-06-09, 05:04 PM)glowntiger Wrote: Hi,
ST1 is availible in the app since 2.1.8 (published today)
be sure pigpio is installed:

Code:
sudo install pigpio

Connect the yellow st1 wire to one of the Inputs: (In1-In4)
In the widget you can chose wich Input you use. On the Data-Output tab you can chosse the UDP Port.
The best way I think is to use SignalK. Make a udp Connection with the Port you choose and set NMEA0183 Data. Then you get all Data in Signal K. An $STALK parser is in the NMEA0183 SignalK app intigratet.
The reason why you only recieve data from the bus is the electric site and owed it that pigpio can only read bitbanging seatalk1!

Hi Thomas, I updated MCS 2.1.8 and added St1, but there is something wrong. SignalK no longer receives the 1W service. I tried to reinstall both the update and the three probes but as you can see from the photo, in MCS they are installed and SignalK does not receive ... Do I have to install "pigpio"? I'm stuck, see photos (I don't want to mix messes with the terminal ..) (OP2 on Rp4 with Moitessier and MCS, no instrument connected, apart from the three probes). If you want to take a look with AnyDesk let me know.  Cool

[img][Image: zkTNij.png][/img]
[img][Image: LV5JAc.png][/img]
[img][Image: IWBESQ.png][/img]
[img][Image: MgMRsS.png][/img]
Reply
Sorry, my mistake:
sudo apt-get install pigpio
Then restart kick save again to restart the service....
Reply
I integrate the pigpio in the next app version.

@Sailoog,
is it possible to do this with the intallation of the deb package? I have add the dependences to the control file... But only get an info after install that the dependence is missing?
Or is the best way to do this in the postinstallation script?

Thanks
Thomas
Reply
(2020-06-05, 11:39 AM) pid=\14155' Wrote:
(2020-06-04, 07:44 PM)niklun Wrote:
(2020-06-03, 01:22 PM)glowntiger Wrote: Hi niklun,
do not know you exactly system setting....
Have you enable the autoshutdown mode in the MCS APP before you have use this mode as described in the Manual?
If you have not enable this widget, the pi stops hard... !!!
Yes, I have enabled the auto shutdown option. Now I don't trust. I turn off the RPI from software, not through MCS switch. But I'd like to turn it off at the switch. Is there any way to control the shutdown dynamics through the MCS switch? This to check if the times are correct.
My system is composed of: RPI 4 - HAT Moitessier - MCS

Thanks

Yes,
if the shutdown enable is activ, shutdown via the 12V enable terminal. Then look if the Pi shuts down or not. The power of the pi shuts off after ca.:40s. Until then the pi have to shut down....

I had the shut down working on 2.1.6 or 2.1.7.  I corrupted my install with a system update so I started from scratch.  I now have 2.1.8 and the power button no-longer shuts the pi off.  I've verified that the checkbox in the MCS app is checked for 'Enable Autoshutdown'.
Reply
Hi Jamie,
on 2.1.8 nothing changed on the shut off Workaround.
You have enable the autoshutdown and save?
The Pi shuts down after the 12V enable is 0 for longer than 2s.
Else i can take a look with AnyDesk on your Pi...
Reply
Yes. It is enabled and saved. And the check ok is checked on reboot.

I had 2.1.6 or 7 working fine. I updated raspbian to raspberry pi OS and my system would no longer boot. Then I read about the bug in the new firmware, so I took the opportunity to start fresh.

I am using the latest OP Moitessier HAT Image, installed skipping the update at the end, loaded the wifi drivers, then the MCS 2.1.8 setup. So, was as bear of an I stall as possible.

I guess I can try to reinstall the MCS app again. Is there anything I can check or do to help debug this?
Reply
try:
ps aux | grep -v grep | grep -i python
is there a called openplotter-MCS-asd service?
Or under:
htop

Btw:
at sturtup the 12V Enable must be true. Else the service did not start. This is because: Your start the Pi without the MCS it should all time shut down... So the Input is watched all time.
Reply
(2020-06-11, 07:54 PM)glowntiger Wrote: try:
ps aux | grep -v grep | grep -i python
is there a called openplotter-MCS-asd  service?
Or under:
htop

pi@openplotter:~ $ ps aux | grep -v grep | grep -i python
pi          96  1.2  0.6  40916 24332 ?        Ss   16:09   0:02 /usr/bin/python3 /usr/local/bin/pypilot_boatimu -q
pi         364  0.8  0.3  24568 15552 ?        Ss   16:10   0:01 /usr/bin/python3 /usr/bin/openplotter-pypilot-read
pi         409  0.1  0.4  40916 18120 ?        S    16:10   0:00 /usr/bin/python3 /usr/local/bin/pypilot_boatimu -q
pi         413  0.0  0.4  41048 18888 ?        S    16:10   0:00 /usr/bin/python3 /usr/local/bin/pypilot_boatimu -q
pi         415  0.1  0.4  40916 18452 ?        S    16:10   0:00 /usr/bin/python3 /usr/local/bin/pypilot_boatimu -q
pi         494  0.9  0.3  32312 14816 ?        Ssl  16:10   0:01 /usr/bin/python3 /usr/bin/openplotter-i2c-read
pi         524  0.4  0.3  22956 14728 ?        Ss   16:10   0:00 /usr/bin/python3 /usr/bin/openplotter-MCS-asd

OK. I found the problem. I have a new powered USB 3 Hub. I watched the voltage drop from 19 to 4.5 volts. Aparently, the power from the USB Hub is back feeding through the USB cable to the Pi. When I unplug the hub and only power it through the Pi, the MCS power button works fine.
Reply
Can I use a rectifier diod to prevent power from back feeding into the pi? I'm going to have to open the hub and find the +5v wire from the USB cable and put it there, correct?
Reply
(2020-06-11, 10:16 PM)jamieFL Wrote: Can I use a rectifier diod to prevent power from back feeding into the pi? I'm going to have to open the hub and find the +5v wire from the USB cable and put it there, correct?

Don´t know. I think there are usb- connectors availible to do something like this. Else you power the USB Hub with the switch you use to power off 12+enable?
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)