This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OP Moitessier Hat
My venture into Open Plotter:  reporting problems and asking a few questions

I don't know if there is a problem with the OpenPlotter documentation or I am misunderstanding something but when installing the Moitessier hat on my Raspberry Pi3B+ at one point you need to match the Kernel to the drivers but the driver list doesn't have what is needed.  There is a link to the latest drivers.  When the drivers download, they don't go into a directory where the software sees them.  I had to manually search the directories until the other drivers were found and then I copied the downloaded file to that directory for the install.  

The destination directory that worked for me was "/home/pi/.config/openplotter/tools/moitessier_hat/packages" with the new driver located in that directory, it popped up on the list and I was able to install it.

The installation completed with an error or two, but the Pi did reboot and the hat worked after that  The terminal screen suggests that you read the log file but doesn't say where it can be found.  Anyone know where the "log" file is located?  

Once I got the Moitessier hat up and configured by going through the setup instructions, it was driving the CPN display but compass heading seems to be a suggestion rather than anything accurate based on the results of my rotation of the Pi.  The required orientation of the Pi isn't documented anywhere.  Does the Pi figure out how the module is mounted and correct itself from there?

I2C setup doesn't allow for editing of the SignalK description.  The field isn't grayed out but typing doesn't result in anything appearing in the name field.

The instructions show a tilt, roll and direction data field which looks quite interesting but my installation doesn't produce one, unless I just haven't found it yet.  Does anyone know where this screen is located?
[Image: assets%2F-L9g5MoJ9GSCaNGq_yjb%2F-LGBfW3x...3e61d10898]

Under SK Diagnostics I get an error statement:  File not found "keyswithmetdata.json".  Any idea why?

The installation onto the SD card resulted in only 6GB of the 16 being included in the partition.  This has prevented me from downloading any charts.  Can anyone tell me how to re-partition the SD card so I have full use of the space?

If you can also tell me where I went wrong in the installation, I will know not to do that in the future.  I downloaded the image and burned it to the SD card.  Noobs didn't boot for me, so I stuck to the image.

I was lucky enough to also buy a Pi4B.  While I have only had minor problems getting the 3B+'s working, the OpenPlotter installations will not work on the Pi4's.  I downloaded Raspberian from in June and didn't have any luck booting the Pi with that image, but downloaded the July version yesterday and got it running without any difficulty.  Will OpenPlotter update their version of Raspberian or should I try to build OpenPlotter on top of my working OS?  I think I read somewhere that these steps are described for a manual installation.  

For now though, my first priority is to re-partition the SD card so that I can continue making changes.  

If anyone knows the answers to my questions above, I'd appreciate your input.
sudo raspi-config
advanced / expand file sys
That worked like a charm! It took less than a minute to expand the partition and reboot.
I spent quite a bit of time trying to find this through Google searches and didn't, so thank you very much for this tip.
You need to calibrate your compass or it will not work. some info here:
and more here:

Next version, better docs Smile

Do not try to run openplotter 1 in RPi4, wait for openplotter 2:
Thanks for the info on the compass and Openplotter 2.

I got to thinking about the Pi4 the other day and have a question about memory usage. If you boot off of the SD card and the charts are also stored on the SD card, what does the extra RAM buy you? What is it used for? I don't see any way of directing files or functions to the internal memory, so it must be more of a matter of how the running programs are written, which makes me wonder if the 4 GB version of the Pi 4 has more utility than a 1 GB version for OpenPlotter purposes.

It would be handy if the Pi could eventually boot off of its internal memory.

Thanks again for the assist. I haven't calibrated it yet, but will report back.

Forum Jump:

Users browsing this thread: 1 Guest(s)