This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] GPSD Stops receiving data when GPS uses more than 4800 baud
For the past three days, I have been investigating an issue where GPS comm and sometimes even Pylot comm simply stops.

After lots of fiddling around, the only solution I could find was using a very old GPS receiver that uses only 4800 baud. My uBlox and Mediatek receivers with baud rates between 9600 and 115200 do not produce stable system on two different Raspberry Pi 3 (+) with various power supplies.

I recently upgraded to OpenPlotter 1.2 Alpha.

Did anyone else experience similar issues?

If I am not wrong nobody reported something similar before.

Anyway, have you considered to start using openplotter 2?

it is still in beta stage but I do not think we will invest more effort in OP 1 to debug.
I have not looked into OpenPlotter 2, yet. Since I'm new to the project anyways, I might as well try it! I'll report back once I have tried it out whether it makes any difference.
The solution was to switch the USB-UART adapter. To be clear: I have a gps module that outputs uart. So I needed an FTDI232RL usb to serial module to connect it. Under Windows this works great even with clones of clones of these FTDI chips. On the Pi3 this causes problems left and right!
Switching the USB to serial converter seems to have solved my instability issues to the gps as well as to my pypilot motor controller.

Forum Jump:

Users browsing this thread: 1 Guest(s)