This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to install Freeboard offline charts?
#1
Hello,
while looking for a way of passing nmea data from my raspberry pi to my VHF Radio i found this amazing project.
I realy like the Freeboard Web based display, is there a way of installing offline charts e.g. OSM KAP-Charts?


Additionaly the Freeboard Maps is not accepting Notes (Error 404) or Waypoints (Server could not update Waypoint details)

Any help highly appreciated.

Best Regards,
Martin
Reply
#2
Hi there,
seems like i need the Signal K Node server Charts plugin @signalk/charts-plugin
i tried to install this via the Appstore and it failed.

Then i tried in console with
pi@openplotter:~ $ sudo /bin/bash
root@openplotter:/home/pi# npm i @signalk/charts-plugin

it tried to install sqlite3 and failed:

> sqlite3@4.1.1 install /home/pi/node_modules/sqlite3
> node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp WARN Tried to download(403): https://mapbox-node-binary.s3.amazonaws....arm.tar.gz
node-pre-gyp WARN Pre-built binaries not found for sqlite3@4.1.1 and node@8.17.0 (node-v57 ABI, glibc) (falling back to source compile with node-gyp)
gyp WARN EACCES current user ("pi") does not have permission to access the dev dir "/root/.cache/node-gyp/8.17.0"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/home/pi/node_modules/sqlite3/.node-gyp"
make: Entering directory '/home/pi/node_modules/sqlite3/build'
make: *** No rule to make target '../.node-gyp/8.17.0/include/node/common.gypi', needed by 'Makefile'. Stop.
make: Leaving directory '/home/pi/node_modules/sqlite3/build'
gyp ERR! build error

i tested to download the sqlite package with wget end got Error 403: Forbidden.

wget https://mapbox-node-binary.s3.amazonaws....arm.tar.gz
--2020-01-01 12:37:46-- https://mapbox-node-binary.s3.amazonaws....arm.tar.gz
Resolving mapbox-node-binary.s3.amazonaws.com (mapbox-node-binary.s3.amazonaws.com)... 52.216.177.203
Connecting to mapbox-node-binary.s3.amazonaws.com (mapbox-node-binary.s3.amazonaws.com)|52.216.177.203|:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2020-01-01 12:37:47 ERROR 403: Forbidden.

Any suggestions?

Best Regards,
Martin
Reply
#3
Please try to install the plugin from the SK admin’s App Store.

Why are you trying it manually?

There are no prebuilt Arm binaries for sqlite3: be warned that the install and compile takes so long that it seems stalled.

If anybody wants to help in adding Arm support here’s a pointer to get started: https://github.com/mapbox/node-sqlite3/issues/418




Sent from my iPhone using Tapatalk
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)