This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrade tinypilot from Git
#11
This would be the answer for h#@schuur's problem, but it's quite advanced fix. Reading what you say, I'd reckon this might also be possible by adjusting /opt/bootlocal.sh and then running filetool.sh -b.

@Sean having built upgrade procedures extensively in the past, I'd recommend some post-migration script built into pypilot.build that would replace or modify the bootlocal script automatically, or do whatever needs to be done to fix this service rename problem, if required.
Reply
#12
thank you for the response

i think i have to wait for a new script or tinypilot version.
i cannot find which services i have to rename.
and of course you have to trust the coding.
Confused
Reply
#13
sorry the new version is taking a while.

I agree that having some sort of upgrade would be nice.

I didn't originally intend users to upgrade tinypilot this way, only by sd image, but it can definitely be added.
Reply
#14
Hello,

I am writing here for a question regarding tinypilot upgrade. I have a raspberry pi zero W with the tinypilot image available from pypilot.org installed on it.

The issue is that I cannot manage to get my IMU ICM20948 detected by the pi. I thought that upgrading tinypilot from git could solve the problem since there was recently an update for this IMU, so I followed the instructions from this thread but the IMU still isn't detected.

I know the IMU is working since I installed instead Raspbian and the latest Pypilot version on my pi and got everything working.

Is there a way to fix/upgrade tinypilot to get the IMU detected ?

Thanks for your help
Reply
#15
the latest image does not support icm20948

You would have to compile RTIMULib2:
https://github.com/seandepagnier/RTIMULib2/

This is a library used by pypilot, the build scripts are in tinypilot which need to make a package for it so it works after reboot. I intend to make the next tinypilot image support them.
Reply
#16
(2021-04-24, 12:22 AM)seandepagnier Wrote: the latest image does not support icm20948

You would have to compile RTIMULib2:
https://github.com/seandepagnier/RTIMULib2/

This is a library used by pypilot, the build scripts are in tinypilot which need to make a package for it so it works after reboot.  I intend to make the next tinypilot image support them.

Ok, thanks a lot for your answer. I will have a look at that.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)