This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] I2C to SIgnal K communication stops
I installed Openplotter 2 on Raspberry PI3 and built a nodered dashboard on the embedded platform.

I also have a BME280 sensor connected via I2CĀ and MPU9250 connected via pyplilot.

As soon as the I2C starts communicating with the SignalK server everyting works fine. I see the communication at 1 delta/s on the Signal K dashboaard.

After 10 to 15 minutes communication stops and the only solution to restart te communication is to reconfigure the sensor in I2C.

When using the nodered embedded BME280 node plugin, the sensor keeps working.
This can be a workaround for the nodered dashboad but the esensor information is no longer in the signalk stream.

Any advice ?

Many thanks
Sailing B473 in Belgium, Europe and Caribean
Please test the new openplotter-i2c v2.0.7 and report. This should be fixed.
I have the same setup (albeit Rpi4) and encountered the same problem. Update seems to have solved the problem. Thanks for the quick fix
Thanks for reporting!

Marking as solved

Forum Jump:

Users browsing this thread: 1 Guest(s)