This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Reporting: Moitessier 2 HAT installation
#1
Installed Basic OpenPlotter Moitessier HAT for RPI 4 (2020-01-13 OpenPlotter-Moitessier-HAT-v2.0-pre-release-NOOBS) on a brand new RPI4 4GB. No HAT attached during the installation. Once done, System check justly reported that Moitessier was not attached (I2C and SPI were OK). Attached the Moitessier 2 HAT, System check still reports not enabled. HAT app was saying that the installed package wasn't supported (see Fig_1). HAT app Drivers tab showed that the current kernel version was a few versions upward of the driver, but the appropriate package could not be selected on the Available packages panel (See Fig_2). I had to press Download to select and manually download the latest driver. Installation was only a matter of double clicking it from the download folder. Afterwards, HAT app Drivers tab was reporting that the new version was installed (see Fig_3) and OP System check was reporting that the HAT was attached (see Fig_4).
 
All in all, quite smooth. Kudos to OP minds. Just curious as to why the appropriate package was not selectable from the drop-down menu in the Available packages panel of the HAT app's Drivers tab. Was it because I made the initial install without the HAT?


Attached Files Image(s)
               
"Your reason and your passion are the rudder and the sails of your seafaring soul."
Khalil Gibran
Reply
#2
My hypothesis is that you clicked on "all drivers" instead of "download" button. Download button does the manual work of "all drivers" for you searching, downloading and installing the correct package.

I detect also a recurrent issue. You made an upgrade of your system and openplotter apps were updated but the post scripts are not ran when you update apps outside the openplotter settings app. If you were updated from settings app the correct package would have been there to select. Working on a solution for this problem today.
Reply
#3
Apologies, you're right. I was presented with all the drivers and selected the latest one, so I must have clicked the "All drivers" button, not "Download".  I'll be more careful tracing my exact steps before reporting. In the moment the workaround was kind of obvious and easy to find, so a very minor issue. Nothing to impair my admiration for all the quality work that is going into OP.
"Your reason and your passion are the rudder and the sails of your seafaring soul."
Khalil Gibran
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)