This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] 3 packages can be upgraded.....no big deal...
#1
No big deal but...

It seems that, after running "Update Candidates" the app is reportng 

Code:
Reading state information...
3 packages can be upgraded. Run 'apt list --upgradable' to see them.


And after an update with "$ sudo apt full-upgrade" it still reports the same.
And then running the update again You will have

Code:
$ sudo apt full-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  openplotter-dashboards openplotter-serial openplotter-signalk-installer
The following packages will be DOWNGRADED:
  openplotter-settings
3 upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 1,116 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://dl.cloudsmith.io/public/openplotter/openplotter/deb/debian buster/main armhf openplotter-settings all 2.0.25-stable [1,022 kB]
Get:2 https://dl.cloudsmith.io/public/openplotter/openplotter/deb/debian buster/main armhf openplotter-dashboards all 2.0.5-stable [26.8 kB]
Get:3 https://dl.cloudsmith.io/public/openplotter/openplotter/deb/debian buster/main armhf openplotter-serial all 2.0.4-stable [39.5 kB]
Get:4 https://dl.cloudsmith.io/public/openplotter/openplotter/deb/debian buster/main armhf openplotter-signalk-installer all 2.0.10-stable [27.3 kB]
Fetched 1,116 kB in 2s (461 kB/s)                   
Reading changelogs... Done
(Reading database ... 96975 files and directories currently installed.)
Preparing to unpack .../openplotter-settings_2.0.25-stable_all.deb ...
Unpacking openplotter-settings (2.0.25-stable) over (2.0.25-stable) ...
Preparing to unpack .../openplotter-dashboards_2.0.5-stable_all.deb ...
Unpacking openplotter-dashboards (2.0.5-stable) over (2.0.5-stable) ...
Preparing to unpack .../openplotter-serial_2.0.4-stable_all.deb ...
Unpacking openplotter-serial (2.0.4-stable) over (2.0.4-stable) ...
Preparing to unpack .../openplotter-signalk-installer_2.0.10-stable_all.deb ...
Unpacking openplotter-signalk-installer (2.0.10-stable) over (2.0.10-stable) ...
Setting up openplotter-serial (2.0.4-stable) ...
Setting up openplotter-settings (2.0.25-stable) ...
Setting up openplotter-dashboards (2.0.5-stable) ...
Setting up openplotter-signalk-installer (2.0.10-stable) ...
Processing triggers for mime-support (3.62) ...
Processing triggers for desktop-file-utils (0.23-4) ...
Running RPi3, latest Buster
________________________________________

Blogg; https://pysselilivet.blogspot.com/
Reply
#2
Yes, I have realized that. Packages in the new repository will be always "upgradables" even if they are at the latest version. No critical but annoying, investigating...
Reply
#3
Solved in openplotter-settings v2.1.0
Reply
#4
(2020-03-03, 05:10 PM)Sailoog Wrote: Solved in openplotter-settings v2.1.0

Thanks for Your feedback ! Highly appreciated.

Been running V2 since August and it has been very stable !

Thanks for a fantastic work !

/Mats
________________________________________

Blogg; https://pysselilivet.blogspot.com/
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)