This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
10.10.10.1:10110
#1
I'm trying to connect to OpenCPN remotely using the address: 10.10.10.1:10110 and it doesn't work

BUT

10.10.10.1:3000 (K Server) does work so I assume my iPad is connected to the RPI correctly. Any thoughts?

(I tried both Headless Mode and None Headless mode)
Reply
#2
Can you get a port scanner app for your iPad? That might tell you if your tablet is actually seeing 10110 at all, and then you can go from there.

I've had problems getting Navionics running on iPad to see OpenPlotter. On Android all I need to do is to create a new device connection, but I had trouble doing that with a friend's iPad.
Reply
#3
(2020-03-09, 03:49 PM)abarrow Wrote: Can you get a port scanner app for your iPad? That might tell you if your tablet is actually seeing 10110 at all, and then you can go from there.

I've had problems getting Navionics running on iPad to see OpenPlotter. On Android all I need to do is to create a new device connection, but I had trouble doing that with a friend's iPad.

Thanks - your suggestion prompted me to try some other stuff and:
  • on my RPi: localhost:10110 doesn't return anything either
  • using the command prompt: nmap -sT -O localhost - doesn't list port 10110
So the "basic" configuration at least: pot 10110 does not seem to be open - so I don't think it's iPad specific.

Any idea how I fix that?
Reply
#4
You can do it a couple of different ways. One is to install the SignalK "SignalK to NMEA0183" plugin, and test to see if you are getting anything out on TCP port 10110 (you should). Don't forget to enable to plugin, and check the NMEA strings you want sent out. If you still can't see it, try also installing the "UDP NMEA0183 Sender". That plugin sends out using UDP and does allow you to configure the network (10.10.10.255) and UDP port you need to send data out on (10110 is fine).

If you don't want to mess with SignalK plugins, you can configure an outgoing network connection in OpenCPN. With that one, you have full flexibility to choose port number, TCP or UDP, addresses, etc. Of course, the downside is that you need to have OpenCPN running on your RPI server.
Reply
#5
(2020-03-09, 06:50 PM)abarrow Wrote: You can do it a couple of different ways. One is to install the SignalK "SignalK to NMEA0183" plugin, and test to see if you are getting anything out on TCP port 10110 (you should). Don't forget to enable to plugin, and check the NMEA strings you want sent out. If you still can't see it, try also installing the "UDP NMEA0183 Sender". That plugin sends out using UDP and does allow you to configure the network (10.10.10.255) and UDP port you need to send data out on (10110 is fine).

If you don't want to mess with SignalK plugins, you can configure an outgoing network connection in OpenCPN. With that one, you have full flexibility to choose port number, TCP or UDP, addresses, etc. Of course, the downside is that you need to have OpenCPN running on your RPI server.

Thanks again for your reply and I'm reasonably technical but I don't understand what is meant to happen here so let me read up on that first before bothering you. What I did on my iPad is use a browser and go to <RPI>:10110 - that didn't work but when you say getting something out of TCP 10110 - I'm guessing that a simple browser won't do the trick.

Again - I think these are basic questions I need to research first not to bother you too much. If I get stuck: I'll come back to you.
Reply
#6
(2020-03-09, 08:50 PM)DoubleDutch Wrote: What I did on my iPad is use a browser and go to <RPI>:10110 - that didn't work but when you say getting something out of TCP 10110 - I'm guessing that a simple browser won't do the trick.

That is correct, a browser understands HTTP and a few other protocols; but what you get out of port 10110 is a NMEA stream which a browser doesn't understand. Your navigation app however can connect to this directly.
Reply
#7
https://localhost:3000/signalk/v1/api/.

npm install -g wscat2
wscat 'ws://localhost:3000/signalk/v1/stream?subscribe=all'

https://github.com/signalk/signalk-server-node
mare liberum
Reply
#8
(2020-03-09, 06:50 PM)abarrow Wrote: You can do it a couple of different ways. One is to install the SignalK "SignalK to NMEA0183" plugin, and test to see if you are getting anything out on TCP port 10110 (you should). Don't forget to enable to plugin, and check the NMEA strings you want sent out. If you still can't see it, try also installing the "UDP NMEA0183 Sender". That plugin sends out using UDP and does allow you to configure the network (10.10.10.255) and UDP port you need to send data out on (10110 is fine).

If you don't want to mess with SignalK plugins, you can configure an outgoing network connection in OpenCPN. With that one, you have full flexibility to choose port number, TCP or UDP, addresses, etc. Of course, the downside is that you need to have OpenCPN running on your RPI server.

Hi - Me again... This is starting to drive me crazy.... Lets take a step back.
  • I found this URL: http://ais.exploratorium.edu:80 which is AIS information for the San Francisco Bay Area. When I open the URL: you will see what I believe to be NMEA AIS Data
  • On my RPI, in OpenCPN I created an input port and point it to the above URL. Now, when in OpenCPN I look at the SFO Bay area: I see AIS targets! Hooray!
  • I now want to see these same targets in Navionics on my iPad and that bit doesn't work
My questions:

  1. Looking at your post above: given that I added this SFO-AIS data to OpenCPN; I have to create the outgoing network connection in OpenCPN because "Signal K" doesn't know about SFO-AIS? I'm not sure how to do that without restricting it to a specific IP address (of my iPad)

  2. Is configuring SFO-AIS in Signal-K an option / is it best practice to configure all inputs in the Signal-K server, so the only connection in OpenCPN is to the Signal K server and my iPad connects to Signal-K not OpenCPN

  3. With the configuration as I currently have it where, as I understand it OpenCPN is the "aggregator" and given the above SFO-URL and having configured the Access Point in OP - why can I not go to http://10.10.10.1:10110 and see this NMEA data (whilst port 3000 does show the Signal K server so the WiFi configuration must be OK?)
Almost losing sleep over this :-)
Reply
#9
(2020-03-09, 10:00 PM)jim321 Wrote: https://localhost:3000/signalk/v1/api/.

npm install -g wscat2
wscat 'ws://localhost:3000/signalk/v1/stream?subscribe=all'

https://github.com/signalk/signalk-server-node

Hi - are these the suggested steps to fix my issue? I will try them later in that case but again I thought that given that e.g. my AIS information is in OpenCPN: signalk is not aware of them. Is that correct?
Reply
#10
Let's start from the beginning - what exactly do you mean by
Quote:I'm trying to connect to OpenCPN remotely using the address: 10.10.10.1:10110 and it doesn't work

From what device, using what application? Your next comment suggests you are using an iPad and a browser? What does "remotely" mean - from outside your boat's network or from another device than your RPi running OpenPlotter? "Connect to OpenCPN" - you mean you'd like to use OpenCPN by sharing its screen on the device? "Connect" could mean many things, like trying to connect to OpenCPN's NMEA0183 output.

Quote:10.10.10.1:3000 (K Server) does work so I assume my iPad is connected to the RPI correctly. Any thoughts?

Yep, but that's about it. How does this relate to your question?

(2020-03-10, 12:56 AM)DoubleDutch Wrote:
(2020-03-09, 06:50 PM)abarrow Wrote: You can do it a couple of different ways. One is to install the SignalK "SignalK to NMEA0183" plugin, and test to see if you are getting anything out on TCP port 10110 (you should). Don't forget to enable to plugin, and check the NMEA strings you want sent out. If you still can't see it, try also installing the "UDP NMEA0183 Sender". That plugin sends out using UDP and does allow you to configure the network (10.10.10.255) and UDP port you need to send data out on (10110 is fine).

If you don't want to mess with SignalK plugins, you can configure an outgoing network connection in OpenCPN. With that one, you have full flexibility to choose port number, TCP or UDP, addresses, etc. Of course, the downside is that you need to have OpenCPN running on your RPI server.

Hi - Me again... This is starting to drive me crazy.... Lets take a step back.
  • I found this URL: http://ais.exploratorium.edu:80 which is AIS information for the San Francisco Bay Area. When I open the URL: you will see what I believe to be NMEA AIS Data
  • On my RPI, in OpenCPN I created an input port and point it to the above URL. Now, when in OpenCPN I look at the SFO Bay area: I see AIS targets! Hooray!
  • I now want to see these same targets in Navionics on my iPad and that bit doesn't work
My questions:

  1. Looking at your post above: given that I added this SFO-AIS data to OpenCPN; I have to create the outgoing network connection in OpenCPN because "Signal K" doesn't know about SFO-AIS? I'm not sure how to do that without restricting it to a specific IP address (of my iPad)

  2. Is configuring SFO-AIS in Signal-K an option / is it best practice to configure all inputs in the Signal-K server, so the only connection in OpenCPN is to the Signal K server and my iPad connects to Signal-K not OpenCPN

  3. With the configuration as I currently have it where, as I understand it OpenCPN is the "aggregator" and given the above SFO-URL and having configured the Access Point in OP - why can I not go to http://10.10.10.1:10110 and see this NMEA data (whilst port 3000 does show the Signal K server so the WiFi configuration must be OK?)
Almost losing sleep over this :-)

Ooh where do I start.....

ais.exploratorium.edu:80 produces a stream of NMEA0183 messages containing AIS messages over TCP.

Browsers, at least Chrome and possibly others, treat port 80 special: they apparently treat it as a text feed. NMEA0183 being essentially lines of text starts flowing on your screen. This will probably not work on any other port - at least when I tried it doesn't work on port 10110 of my Signal K server, even if it produces a similar data stream. So http://10.10.10.1:10110 just will not work.

In OpenPlotter 2 I would set up the connections like so
- Add TCP NMEA0183 connection in SK server to ais.exploratorium.edu:80
=> all SK server nmea0183 input is automatically available at port 10110 and you get the data also in the Signal K system and apps, for example in Freeboard
- Add TCP connection in OpenCPN to localhost 10110
=> this will bring the same data to OpenCPN
- Add NMEA0183 in your navigation app in your iPad/device to 10.10.10.1:10110
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)