This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Help - One Wire sensors stopped working.
Hi all, I have a set of one wire sensors that just just left the building... There are seven of them (with reduced resistor to make them all work) and they are hooked up onto an ESP8266 running SigKsens and have been working flawlessly for a couple off weeks now. 
Today they were all gone. I have not touched anything, and the voltage read from the analog port on the same ESP shows up with correct value. When I look at the sensor in my browser, they are there, but as seen in the image they all give value "null", or a simple dash in signal K. 

Anyone experienced anything like it before? Typically - I was putting final touches on THIS part of my build today...
This is what I have been experiencing for a long time already and the exact reason I’m rebuilding my esp with SensESP instead of SigkSens.
Would you happen to use a second WiFi via usb?
Asking because it could have to do with mDNS that gave me more problems.
(2020-03-16, 07:04 PM)Blue Ocean Wrote: This is what I have been experiencing for a long time already and the exact reason I’m rebuilding my esp with SensESP instead of SigkSens.
Would you happen to use a second WiFi via usb?
Asking because it could have to do with mDNS that gave me more problems.

Yes I have a second Wifi on an USB dongle. The ESP8266 is up and running, and I can get it's internal data (uptime, mhz, and memory) as well as the status of the analog port where I have a voltmeter. The 1W sensors are all gone though. They show "null" and not "NaN" as they did when the connection wire was off...
It is just my suspicion there is something wrong with mDNS in combination with extra WiFi over USB having something to do with these problems. After I built a SensESP it didn't connect at all until I ran:
# cd /usr/lib/node_modules/signalk-server
# sudo npm install --unsafe-perm mdns
And it is completely stable now connecting over the ext. USB-wifi while the SigKSens still looses connection now and then. It also does not connect until I have restarted signalk-server one to three times.

But your problem seems different. You do get system-data from the ESP. So there must be something with the 1wire bus. Do you have the 4k7 resistor between data and 3.3v? And you are using the 3.3v as supply? Connected to the correct pin? D7 in my case but I have seen somewhere mentioning D5.

May I ask what you are using for voltmeter input? Just a resistor divider? How about calibration? In software?
Battery-monitoring, at least voltage, is next on my list.
Yep - I am using the resistor, but as I have 7 of them connected, I needed to reduce the resistor. I think I ended up with a 2K to make all the sensors work. When I had the 4K7, the sensors showed as NaN after the third sensor. The sensors HAVE been working and I've run tests for a few weeks. Now they all died.
As for my voltmeter, I am using this and it is churning on. :-D Will go on Corona leave and trouble shoot today.
After some procrastination, I decided to tear it all down and take the ESP and a couple of sensors home to see if I could understand what went wrong. Turned out ONE of the sensors had died, thereby compromising the entire bus, which gave no signals from the rest of the sensors. SO - if you get "-" or value "null" from your 1W sensors, only one of them might be the bad guy. I had 7 sensors on my D1 Mini. So far I have re attached 3 and they all seem to be running. One question though - is there a better way to connect the 1W sensors than a star?
The star is actually a collapsed 'bus'.

So you could run one cable with three wires to the next sensor instead of running separate cables for each sensor. But I don't think that is doable, especially not when using the waterproof version with cable already attached.
For now I have just four sensors for the engine-room and did it like this:


With 3.5mm jacks. Not watertight, I know. But the box is above the waterline so if this box floods I have a bigger problem.
I actually discussed the mini jack solution with a friend earlier on, as troubleshooting would have been SOOO much easier. :-D
Ha! I THOUGHT I had solved it, but it seems like I had a combo of problems. Had to tear out the whole shebang and test systematically. It seems like I didn't READ the SigKSens instructions, but just looked at the pictures for connections. I had connected the 18WS20D (1W) sensors to 5V rather than 3.3V. (as shown on the illustration for SigKSens. While this works for the Arduino, the D1 Mini do not appreciate the extra voltage... So The port was fried on the D1. Changing to pin D6, recompiling, and attaching the old temp sensors seem to work. Will benchtest for a while, then throw it all back into the boat. Undecided
Today - polyester and glasfiber though... :'(

Forum Jump:

Users browsing this thread: 1 Guest(s)