This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
... get my own Can USB Converter
(2019-02-26, 11:56 AM)e-sailing Wrote:
(2019-01-18, 11:34 AM)verkerkbr Wrote: I have read that the use of the Actisense software for reading the NMEA2000 data is licensed and perhaps the use is illegal.

Why do you want to use Actisense NMEA reader PC-Software on the raspberry pi ???
There is no need to use any Actisense software with openplotter. And openplotter, canboat and signalk are all open source.

If openplotter detects can0 it should be able to do all the settings in signalk.

Hi E-sailing,

I'am only a user. But as far as I know most applications use the Actisenses codes. Based on the NTG-1 convertor.

Can0 is not detected in the OpenPlotter menu, because it expects actisense ?

Therefore I had to make the connections in the SignalK setup.

If you are interested I can give a detailed description, what I have done to get this working.

This very small board has to be set to the standard for NMEA2000 with the bitrate of 250K.

The board has two jumpers. One for terminal on/off and one for flashing the firmware. I have flashed the firmware first (Candlelight)

You have to activate the board in Linux with the command:

sudo ip link set can0 up type can bitrate 250000 (Default is 500K) 250K is de bitrate for NMEA2000

Then you have can0 on your system.

You can check this after installing can-utils.

In one terminal: cansend can0 999#DEADBEEF
In terminal two: candump can0

Now you have the proof of can0 on your system.

Further you have to make the settings in SignalK servers:

Nmea2000 source Canbus(canboat)
Interface can0

Setting switches to on

Also switch on OPkplex and the
converter NMEA2000 NMEA0183

Then the choice what sentences you like to receive for NMEA0183

In OpenCPN the setting is localhost 10110

In OPcan you the choice between:
Actisense NTG-1 (canboat)
Actisense NTG-1 (canboatjs)
Canbus (canboatjs)
Canbus (canboat)

I have used Canbus (canboat).


I needed to investigate a missing signal from my wind speed transducer in the top of my mast. I had an Arduino Due and a CANtransmitter laying around so I tested the code from Timo Lappalinen that I downloaded in to my DUE, and it worked "right out of the box" . I also tried it with openplotter 1.20 with great results. Here's a link to my video I made when checking out my wind speed transducer.

I will try the code Timo made for the Teensy board. Just to reduse size.

...I was able to repair my transducer now when I took the the boat out of the water for the winter.
Hi E-sailing,

that is just what I wrote. The Canable board is working without Actisense codes but with Can.js.

The OpenPloter Canbus module however does work with the Actisense codes.

I have not tried the latest Can settings in OP 2.00. I make a direct input in SignalK.

I encouter 3 problems:

I have to initiatlisate the board with a commando in the terminal. Then I have Can0. This can later also easy be done in the startup.

I'am using a Navico transponder with NMEA2K. The output of the transponder recognise the NMEA2K output only by switching it on
after the ini of the board. Otherwise it does not see a connection on the NMEA2K connector.

Then I have to restart the Signal server.

I can use all the SignalK settings and the conversion to nmea183 for OpenCPN.



Forum Jump:

Users browsing this thread: 1 Guest(s)