This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Boot Raspberry Pi / OpenPlotter 2 From USB SSD
***   UPDATE: 08/29/2020   ***

Refer to this post on this thread for an updated step-by-step instructions on how to utilize the native boot from SSD that has been added to the Raspbery Pi 4:  This method has been tested on the above date and does not break the Moitessier HAT firmware.

***   UPDATE: 08/29/2020   ***

First.  I'm new here.  I searched to see if anyone else has done it, and didn't find much, so since I got it working, I decided to post.  I tried a few methods and the one that worked for me is found here:

Raspberry Pi 4 USB Boot Config Guide for SSD / Flash Drives

I had a 64gb SSD out of an old laptop so all I needed was a USB cable.  I purchased the recommended StarTech 2.5" SATA to USB 3.0 Adapter from Amazon and followed the outlined steps almost exactly.  I already had my SSD drive prepared with a new partition, fresh format, and new install of OpenPlotter, so I saw no need to go though those steps again.  After reinstalling my USB Wifi adapter, installing the drivers, and downloading the charts, OpenCPN is running much better.

[Image: IMG_20200419_103537_983-scaled.jpg]
I wish I could have this setup on my boat.

[Image: IMG_20200419_103407_172-scaled.jpg]
This shows the two volumes, one is the micro SD card in the Pi, and the other is the USB SSD.

I hope this is useful to someone here.  I'm quite satisfied, myself, since at the start, I knew nothing about Raspberry Pi or OpenPlotter.  At the beginning of the month, I'm going to try and purchase a Moitessier HAT and experiment with that.  Unfortunately, it looks like they are not shipping because of this virus.  Confused   I cannot decide if I want to go headless, or with a touch screen.  My preference would be with the screen, but I cannot seem to find a good waterproof touchscreen option.
Oops. I posted on the wrong thread. Can it be moved?
moved to "How I did it" thanks
I just ran a speed-test. The results are pretty amazing:

Raspberry Pi Diagnostics - version 0.4
Fri May 15 18:42:11 2020

Test : SD Card Speed Test
Run 1
Sequential write speed 101763 KB/sec (target 10000) - PASS
Random write speed 2137 IOPS (target 500) - PASS
Random read speed 3715 IOPS (target 1500) - PASS
Good mornig,
I would like to check this solution. Can you tell us which version of op you use (img or noobs) and some more specification of the step you do. Thank you

Inviato dal mio ANE-LX2 utilizzando Tapatalk
I used an image. The NOOBS has a recovery partission and I don't think it will work. The instructions are already written. Just follow the guid that I did.
pi 4 eeprom with USB boot seems nearly ready . . . (beta)

more info on
After a few trials and errors and a couple of hours (well, a little more . . . ), I succeed to have my RPi4 booting from a 480 GB USB solid state drive (SSD) without the need of a SD card in the dedicated slot.

I am not familiar with Linux/Raspbian and so rely entirely on instructions found on Internet.

Basically, I started with an image of Openplotter  (Basic Moitessier Hat, I tried without success with the NOOBS) on a 16GB SD card, updated and upgraded the software (it did not work with the original kernel found on the image)  by  opening the terminal

# update your RPI
sudo apt update -y
sudo apt upgrade -y
sudo rpi-update

# reboot now
sudo reboot now

changed the EEPROM to the last beta version (2020-05-15)

# install the rpi-eeprom
sudo apt install rpi-eeprom

# Edit the rpi-eeprom and replace "critical" to "beta"
sudo nano /etc/default/rpi-eeprom-update

# Update/Install the beta eeprom
sudo rpi-eeprom-update -d -f /lib/firmware/raspberrypi/bootloader/beta/pieeprom-2020-05-15.bin

# reboot now
sudo reboot now

After the reboot, I connected my USB SSD and copied the SD card to the USB SSD with the RPi SD card copier software included in Openplotter. (Note I had no success with the sudo sync -avx . . . command in terminal nor with sudo cp ).

FYI, my SSD is a Kingston UV500 SUV500MS/480G memory card in a Renkforce – TED-U31SCRA1 enclosure.

So far, the only problem I encounter is the software for the Moitessier Hat that is not compatible with the latest version of the kernel.

References: the 2 links I gave yesterday and
I was just going to mention the that. With the new beta release you installed, the HAT stops working. I just discovered that and posted about that in the General forum.

The instructions I previously followed worked flawlessly, but now, I wouldn't do it. I'm sure that the HAT driver's will be updated soon and all will be well.
Bad news guys. I am afraid we will not update the Moitessier HAT drivers to that kernel version.

Using rpi-update you get the pre-release and beta kernel version:

Moitessier drivers are built automatically but only when a stable kernel version is published. You should install beta kernels only for development purposes.

Forum Jump:

Users browsing this thread: 1 Guest(s)