This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SDR AIS available in OpenPlotter 2
#71
SignalK is the data server. You can look at the signalK dashboard via your browser with localhost:3000.

The available data then can be used in OpenCPN via an internal network link with the SignalK server called locaLhost. If you use the latest OpenCPN 5.2 data input can allready be done in the SignalK format.

network signalK localhost port 3000
or with an older OpenCPn version: tcp localhost port 10110

Bram
Reply
#72
Bram, just sent you a PM
Reply
#73
Well, was playing around with signalK, opencpn 5.0.0 and the RTL-dongle yesterday evening as well as this morning.
I still haven't managed to get the AIS working...

During calibration to get the right PPM, when searching the GSM900 it does say that the values might be too different and that the PPM might be way off.
I've done many calibration now and I keep ending up with a PPM of -2.
Then I edit the AIS line and put in the gain of 49.6 and the PPM of -2.

When I open SignalK, it does say RTL connected to localhost 10110 but no data coming up.
Settings in SignalK for RTL device are TCP client, localhost and 10110.

I must be missing something that is causing it not to work, the only question is what...

KR

Jo
Reply
#74
Hi Jo,

if you follow the instructions it must work. But you need to do another thing. That is to start the process. Prossesses settings. Switch on the Ais and start the server. Then it is running.

But there must some Ais objects in your area. It works here very well. On my RPI and on my Linux Mint AMD64.

Woon je in Nederland ?

Bram
Reply
#75
Hey Bram,

Belgium, flemish part near Brugge.
The’re be must ais signals around, we’ve got some canals that are used by cargo vessels.

Do you have fb/messenger? Maybe you could assist me via messenger?

Kr

Jo
Reply
#76
Allo Jo, I live just across the Scheldt rivers. You can send me a message in the Dutch/Flemisch language. Perhaps I can help you.

Groeten uit Zeeland,

Bram
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)