This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Remove Nodered login
#1
Hello,

I have several dashboards under nodered embedded to visualise some sensors on the boat.

To make the dashboard more userfriendly and foolproof  I want to remove authentication from the dashboard.
Any idea how to do this 

Many thanks
Bart
Sailing B473 in Belgium, Europe and Caribean
Reply
#2
I have the same question. I would like to be able to disable the node-red password when the dashboard opens and if possible keep the password in flow editing.

it's possible?

Saludos
Reply
#3
You could try with an url like http://openplotter.local@password/Index.html
Reply
#4
I found this settings.js file
/home/pi/.signalk/node_modules/node-red/settings.js

Normally her you can disable the authentication but the authentication part is diabled.
Maybe we have to look into Signal K authentication.

(2020-04-23, 05:42 PM)holgerw Wrote: You could try with an url like http://openplotter.local@password/Index.html

This is not working
Sailing B473 in Belgium, Europe and Caribean
Reply
#5
Just change the sign in option in signalK to "365d" for a year and then you will not have to log on each time.

Had the same issue. Changing it to 365d took care of it for me
Reply
#6
(2020-04-24, 04:59 PM)Opie91 Wrote: Just change the sign in option in signalK to "365d" for a year and then you will not have to log on each time.

Had the same issue. Changing it to 365d took care of it for me

I changed this now to 365 days. Not the best solution but for now this will do the job.

Thank you
Sailing B473 in Belgium, Europe and Caribean
Reply
#7
Hello Bart

my URL was a little wrong, the correct with PASS & USER is like this:
http://username:password@website

of course this is unsecure as it is cleartext.
maybe at som sites you could use an hashed password also = bit more secure

good luck - holger

Just checked again, this will work only with simple Webservers. For nodered Dashboard you have to Login at Server:3000 first. Maybe there at the login it will work with the URL....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)