This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MPU-9250 not detected
#21
We are working hard on OpenPlotter v3 but it will take some time because this time we have 32bit and 64bit and this time we are writing docs at the same time (no docs, no apps).

There were also some important improvements waiting for a major revision like this one and we can say that OP v3 will be the most robust and stable of all of them. There is a lot of work but we are progressing well, a new app is published every week: https://forum.openmarine.net/showthread.php?tid=3878

pypilot and IMU management are obviously in the list but you can already play with OP v3 betas and installing pypilot manually.
Reply
#22
Hi,

Digging up this thread a bit. I'm having similar issue to many users in this thread which is strange.

My configuration is the following :

Raspberry Pi 3 with the following image : https://pypilot.org/download.php?Down=im..._16.img.xz

When I run pypilot_boatimu I have the following output :


Code:
imu process 4290
pypilotServer process 4292
failed to load pypilot.conf not enough values to unpack (expected 2, got 1)
server setup has 3 pipes
made imu process realtime
Using settings file RTIMULib.ini
Settings file not found. Using defaults and creating settings file
Failed to open SPI bus 0, select 0
Using fusion algorithm Kalman STATE4
ERROR: No IMU Detected 228.716127516
warning, failed to make calibration process idle, trying renice
imu rate set to rate 20
setting initial gyro bias [-1.566, -0.837, 0.119]
server add socket ('127.0.0.1', 40534)
server add socket ('127.0.0.1', 40536)
calibration loaded, starting 4289
server, remove socket ('127.0.0.1', 40536)
server add socket ('127.0.0.1', 40538)
server, remove socket ('127.0.0.1', 40534)
server, remove socket ('127.0.0.1', 40538)
server add socket ('127.0.0.1', 40540)
server, remove socket ('127.0.0.1', 40540)

I know connection is well made because I find the MPU on the i2c bus with :


Code:
tc@pypilot:~/i2c-tools$ sudo i2cdetect -y 1
    0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- 69 -- -- -- -- -- --
70: -- -- -- -- -- -- -- --


And I also tried with the address 0x68.

This is really strange that we are many with the same problem. Do you guys have any news on this ?

Thanks Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)